POJ 1250 模拟题

     终于在POJ上碰到一道简单题,,不容易啊。。模拟,可以轻松水过。。题目:

Tanning Salon
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 5582 Accepted: 3052

Description

Tan Your Hide, Inc., owns several coin-operated tanning salons. Research has shown that if a customer arrives and there are no beds available, the customer will turn around and leave, thus costing the company a sale. Your task is to write a program that tells the company how many customers left without tanning. 

Input

The input consists of data for one or more salons, followed by a line containing the number 0 that signals the end of the input. Data for each salon is a single line containing a positive integer, representing the number of tanning beds in the salon, followed by a space, followed by a sequence of uppercase letters. Letters in the sequence occur in pairs. The first occurrence indicates the arrival of a customer, the second indicates the departure of that same customer. No letter will occur in more than one pair. Customers who leave without tanning always depart before customers who are currently tanning. There are at most 20 beds per salon. 

Output

For each salon, output a sentence telling how many customers, if any, walked away. Use the exact format shown below. 

Sample Input

2 ABBAJJKZKZ
3 GACCBDDBAGEE
3 GACCBGDDBAEE
1 ABCBCA
0

Sample Output

All customers tanned successfully.
1 customer(s) walked away.
All customers tanned successfully.
2 customer(s) walked away.
ac代码:

#include <iostream>
#include <string>
#include <cstdio>
using namespace std;
int numbed,visted[30];
int main(){
	//freopen("11.txt","r",stdin);
	while(scanf("%d",&numbed),numbed){
	  memset(visted,0,sizeof(visted));
	  string ss;
	  cin>>ss;
	  int num=numbed;
	  int sum=0;
	  int len=ss.size();
	  for(int i=0;i<len;++i){
		  if(visted[ss[i]-'A']==2)
			  continue;
		  else if(num<=0&&!visted[ss[i]-'A']){sum++;visted[ss[i]-'A']=2;}
		  else if(!visted[ss[i]-'A']&&num){
		    visted[ss[i]-'A']=1;
			num--;
		  }
		  else if(visted[ss[i]-'A']){
		    num++;
		  }
	  }
	  if(sum==0)printf("All customers tanned successfully.\n");
	  else printf("%d customer(s) walked away.\n",sum);
	}
  return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值