杭电 HDU 1016 Prime Ring Problem

http://acm.hdu.edu.cn/showproblem.php?pid=1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19395    Accepted Submission(s): 8654


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

用的深搜

AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int nub[50];
int out[50];
int n;

void Dfs(int b,int s)
{
    int now,next;
    int i,sum,j,p;
    now = b;       //当前第时在几个数
    out[now] = s;  //把满足条件的数存到输出数组中
 //   printf("b:%d s:%d\n",b,s);
    if(b < n)      //判断数是否排满
    {
        for(i = 2; i <= n; i++)   //把还没有到的数加进去尝试一下
        {
            next = i;
            if(nub[next] == 0)   //判断此数没有被用
            {
                p = 0;
                sum = s + next;
                for(j = 2; j < sum; j++) //判断和是否为素数
                {
                    if(sum%j==0)
                    {
                        break;
                    }
                    else
                    {
                        p++;
                    }
                }
                if(p == sum-2)
                {
                    nub[next] = 1;
                    Dfs(b+1,next);
                    nub[next] = 0;
                }
            }
        }
    }
    else
    {
        sum = out[1] + out[n];
        p = 0;
        for(j = 2; j < sum; j++)
        {
            if(sum%j==0)
            {
                break;
            }
            else
            {
                p++;
            }
        }
        if(p == sum-2)
        {
            printf("%d",out[1]);
            for(i = 2; i <= n; i++)
            {
                printf(" %d",out[i]);
            }
            printf("\n");
        }

        return ;
    }
}

int main()
{
    int i,x,y;
    i = 0;
    while(scanf("%d",&n)!=EOF)
    {
        x = y = 1;
        i++;
        memset(nub,0,sizeof(nub));
        nub[1] = 1;
        printf("Case %d:\n",i);
        Dfs(x,y);
        printf("\n");
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值