Fire Station

Description

A city is served by a number of fire stations. Some residents have complained that the distance from their houses to the nearest station is too far, so a new station is to be built. You are to choose the location of the fire station so as to reduce the distance to the nearest station from the houses of the disgruntled residents.

The city has up to 500 intersections, connected by road segments of various lengths. No more than 20 road segments intersect at a given intersection. The location of houses and firestations alike are considered to be at intersections (the travel distance from the intersection to the actual building can be discounted). Furthermore, we assume that there is at least one house associated with every intersection. There may be more than one firestation per intersection.


Input



The first line of input contains two positive integers: f,the number of existing fire stations (f <= 100) and i, the number of intersections (i <= 500). The intersections are numbered from 1 to i consecutively. f lines follow; each contains the intersection number at which an existing fire station is found. A number of lines follow, each containing three positive integers: the number of an intersection, the number of a different intersection, and the length of the road segment connecting the intersections. All road segments are two-way (at least as far as fire engines are concerned), and there will exist a route between any pair of intersections.

Subsequent test cases are separated with a single blank line.


Output



You are to output a single integer for each test case: the lowest intersection number at which a new fire station should be built so as to minimize the maximum distance from any intersection to the nearest fire station.


Sample Input



1 6
2
1 2 10
2 3 10
3 4 10
4 5 10
5 6 10
6 1 10


Sample Output



5


这道题意思真难懂,首先输入数据,第一行两个数分别表示消防站和十字路口的个数,

第二行表示消防站所在的路口,接下来若干行表示每个十字路口的相连和长度,最后

输入会有一个空行结束(坑死在这里了),找到每个十字路口距离最近的消防站,求出

在最小坐标建立消防站使得最远距离最小。


可以先求出每个消防站到每个点的距离,统计每个点的最小值就是各点到消防站的最

短路,统计一个最大就是得到距离消防站最远距离是多少了,然后对每个没有处理

的十字路口进行假设此处有一个消防站,求出距离最近的消防站的最大距离是否比

开始求出的最大值小,如果小那么此点设一个消防站就更优一些。

#include <stdio.h>
#include <vector>
#include <queue>
#include <string.h>
#define INF 0x3f3f3f3f
using namespace std;
const int maxn = 505;
int f[maxn], dis[maxn], m, ans[maxn];
bool vis[maxn];
char str[maxn];
struct node
{
    int v, len;
} t;
vector < node > mp[maxn];
queue < int > q;
void init ( )
{
    for ( int i = 0; i <= m; i ++ )
        mp[i].clear ( );
    memset ( ans, 0x3f, sizeof ( ans ) );
    memset ( f, 0, sizeof ( f ) );
}
inline int Max ( int a, int b )
{
    return a > b ? a : b;
}
inline int Min ( int a, int b )
{
    return a < b ? a : b;
}
void spfa ( int s ) //求单源最短路
{
    for ( int i = 1; i <= m; i ++ )
        vis[i] = false, dis[i] = INF;
    while ( ! q.empty ( ) )
        q.pop ( );
    dis[s] = 0;
    q.push ( s );
    while ( ! q.empty ( ) )
    {
        int u = q.front ( );
        q.pop ( );
        vis[u] = false;
        for ( int i = 0; i < mp[u].size ( ); i ++ )
        {
            t = mp[u][i];
            if ( t.len+dis[u] < dis[t.v] )
            {
                dis[t.v] = t.len+dis[u];    //更新s-v的最短路
                if ( vis[t.v] == false )    //没有进队列
                {
                    vis[t.v] = true;
                    q.push ( t.v );
                }
            }
        }
    }
}
void print ( )
{
    for ( int i = 1; i <= m; i ++ )
        printf ( "%d ", dis[i] );
    printf ( "\n" );
}
int main ( )
{
    int n, x, u, v, l, res, id;
    while ( ~ scanf ( "%d%d", &n, &m ) )
    {
        init ( );
        for ( int i = 0; i < n; i ++ )
        {
            scanf ( "%d", &x );
            f[x] = 1;
        }
        getchar ( );
        while ( gets ( str ) && strlen ( str ) )    //注意这里是多组,不是m组
        {
            sscanf ( str, "%d%d%d", &u, &v, &l );
            t.v = v, t.len = l;
            mp[u].push_back ( t );
            t.v = u;
            mp[v].push_back ( t );
        }
        for ( int i = 1; i <= m; i ++ )
        {
            if ( f[i] ) //求出每个消防站到每个十字路口的距离
            {
                spfa ( i );
                for ( int j = 1; j <= m; j ++ )
                //找每个十字路径距离最近的消防站
                    ans[j] = Min ( ans[j], dis[j] );
                //print ( );
            }
        }
        res = 0;
        for ( int i = 1; i <= m; i ++ ) //找距离最远
            res = Max ( res, ans[i] );
        id = 1;
        for ( int i = 1; i <= m; i ++ )
        {
            if ( f[i] == 0 )    //对每个没求过的十字路口假设设定一个消防站,求出最优值
            {
                spfa ( i );
                int mx = 0;
                for ( int j = 1; j <= m; j ++ ) //找距离最近的最大值
                    mx = Max ( mx, Min ( ans[j], dis[j] ) );
                if ( mx < res ) //res大于mx证明在i这个位置更优一些
                {
                    res = mx;
                    id = i;
                }
            }
        }
        printf ( "%d\n", id );
    }
    return 0;
}


在使用Python来安装geopandas包时,由于geopandas依赖于几个其他的Python库(如GDAL, Fiona, Pyproj, Shapely等),因此安装过程可能需要一些额外的步骤。以下是一个基本的安装指南,适用于大多数用户: 使用pip安装 确保Python和pip已安装: 首先,确保你的计算机上已安装了Python和pip。pip是Python的包管理工具,用于安装和管理Python包。 安装依赖库: 由于geopandas依赖于GDAL, Fiona, Pyproj, Shapely等库,你可能需要先安装这些库。通常,你可以通过pip直接安装这些库,但有时候可能需要从其他源下载预编译的二进制包(wheel文件),特别是GDAL和Fiona,因为它们可能包含一些系统级的依赖。 bash pip install GDAL Fiona Pyproj Shapely 注意:在某些系统上,直接使用pip安装GDAL和Fiona可能会遇到问题,因为它们需要编译一些C/C++代码。如果遇到问题,你可以考虑使用conda(一个Python包、依赖和环境管理器)来安装这些库,或者从Unofficial Windows Binaries for Python Extension Packages这样的网站下载预编译的wheel文件。 安装geopandas: 在安装了所有依赖库之后,你可以使用pip来安装geopandas。 bash pip install geopandas 使用conda安装 如果你正在使用conda作为你的Python包管理器,那么安装geopandas和它的依赖可能会更简单一些。 创建一个新的conda环境(可选,但推荐): bash conda create -n geoenv python=3.x anaconda conda activate geoenv 其中3.x是你希望使用的Python版本。 安装geopandas: 使用conda-forge频道来安装geopandas,因为它提供了许多地理空间相关的包。 bash conda install -c conda-forge geopandas 这条命令会自动安装geopandas及其所有依赖。 注意事项 如果你在安装过程中遇到任何问题,比如编译错误或依赖问题,请检查你的Python版本和pip/conda的版本是否是最新的,或者尝试在不同的环境中安装。 某些库(如GDAL)可能需要额外的系统级依赖,如地理空间库(如PROJ和GEOS)。这些依赖可能需要单独安装,具体取决于你的操作系统。 如果你在Windows上遇到问题,并且pip安装失败,尝试从Unofficial Windows Binaries for Python Extension Packages网站下载相应的wheel文件,并使用pip进行安装。 脚本示例 虽然你的问题主要是关于如何安装geopandas,但如果你想要一个Python脚本来重命名文件夹下的文件,在原始名字前面加上字符串"geopandas",以下是一个简单的示例: python import os # 指定文件夹路径 folder_path = 'path/to/your/folder' # 遍历文件夹中的文件 for filename in os.listdir(folder_path): # 构造原始文件路径 old_file_path = os.path.join(folder_path, filename) # 构造新文件名 new_filename = 'geopandas_' + filename # 构造新文件路径 new_file_path = os.path.join(folder_path, new_filename) # 重命名文件 os.rename(old_file_path, new_file_path) print(f'Renamed "{filename}" to "{new_filename}"') 请确保将'path/to/your/folder'替换为你想要重命名文件的实际文件夹路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值