(advanced) UVA 优先队列+贪心 1316 Supermarket

A supermarket has a set Prod of products on sale. It earns a profit px for each product x in Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell from Prod such that the selling of each product x in Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is . An optimal selling schedule is a schedule with a maximum profit.

For example, consider the products Prod={a,b,c,d} with (pa,pa=(50,2), (pb,pb=(10,1), (pc,pc=(20,2), and (pd,pd=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.

Input 

A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.

Output 

For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.

Sample Input 

4  50 2  10 1   20 2   30 1

7  20 1   2 1   10 3  100 2   8
2
5 20  50 10

Sample Output 

80
185
The sample input contains two product sets. The first set encodes the products from table 1. The second set is for 7 products. The profit of an optimal schedule for these products is 185.


题意:商店有若干个商品,每个商品有自己的价值和售卖的最终日期,超过了这个时间,这个商品就不能卖出去了。一天只能买一件商品。问你满足上述要求的情况下,最多能卖多少钱。


思路:我们先把物品按照期限升序排列,那么当我们考虑一个物品卖不卖的时候,如果之前选出的商品个数小于当前考虑的商品的期限,那么我们直接先取当前物品。否则的话,我们尝试将以前选择的一件价值最小的物品进行交换,如果那个最小价值的物品比当前物品的价值要大,那么显然这个物品不选,否则的话,我们只需要交换这两个商品就能得到更好的收益。 所以我们要用一个优先队列储存已经选了的物品的价值。到这里,相信大家已经知道要怎么做了。


代码:

#include<iostream>
#include<cstdio>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
using namespace std;
const int maxn = 10000 + 5;
int n;

struct Item
{
	int deadline;
	int val;
	Item(int d, int v)
		:val(v), deadline(d) { }
	Item() { }
	bool operator<(const Item&it) const
	{
		if (deadline == it.deadline) return val > it.val;
		return deadline < it.deadline;
	}
}item[maxn];

void input()
{
	for (int i = 0; i < n; ++i)
	{
		int v, d;
		scanf("%d%d", &v, &d);
		item[i] = Item(d, v);
	}
	sort(item, item + n);
}

void solve()
{
	priority_queue<int> q;
	int ans = 0;
	for (int i = 0; i < n; ++i)
	{
		if (item[i].deadline>q.size())
		{
			q.push(-item[i].val);
			ans += item[i].val;
		}
		else if (item[i].val > -q.top())
		{
			ans += q.top(); q.pop();
			ans += item[i].val;
			q.push(-item[i].val);
		}
	}
	printf("%d\n", ans);
}

int main()
{
	while (scanf("%d", &n) == 1)
	{
		input();
		solve();
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值