【最小权值覆盖】Going Home

Going Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13072 Accepted: 6726

Description

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man.

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point.

You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28


要注意一个很重要的地方,要注意降低标准的时候。因为要找delta的最小值,一定要判断delta是否会小于等于零,不能取小于等于零,因为这样便无法不会提高标准了。


#include <cstring>
#include <cstdio>

#define ABS(a) ((a)>0?(a):-(a))
#define DIST(a,b) (ABS(home[b].i-man[a].i)+ABS(home[b].j-man[a].j))
#define MIN(a,b) ((a)<(b)?(a):(b))
#define INSERT(a,b,c) (edge[a][b] = (c))

const long inf = 0x7f7f7f7f;
char map[220][220];
struct node
{
	long i;
	long j;	
};
node home[220];
node man[220];
bool vis[220];
long cntm = 0;
long cnth = 0;
long edge[220][220];
long lnk[220];
long lx[220];
long ly[220];

bool Hungary(long u)
{
	vis[u] = true;
	for (long v=cntm+1;v<cntm+cnth+1;v++)
	{
		if (edge[u][v] && !vis[v] && lx[u]+ly[v]==edge[u][v])
		{
			vis[v] = true;
			if (!lnk[v] || Hungary(lnk[v]))
			{
				lnk[v] = u;
				return true;
			}
		}
	}
	return false;
}
	
int main()
{
	freopen("going_home.in","r",stdin);
	freopen("going_home.out","w",stdout);
	
	long n = 0;long m = 0;
	while (1)
	{
		scanf("%ld%ld",&n,&m);
		memset(man,0,sizeof man);
		memset(lx,0x7f,sizeof lx);
		memset(home,0,sizeof home);
		memset(ly,0,sizeof lx);
		memset(edge,0,sizeof edge);
		memset(lnk,0,sizeof lnk);
		memset(map,0,sizeof map);
		cntm = 0;cnth = 0;
		if (n == 0 && m == 0) break;
		for (long i=1;i<n+1;i++)
			for (long j=1;j<m+1;j++)
			{
				while ((map[i][j]=getchar())==' '||map[i][j]=='\n');
				if (map[i][j] == 'H')
				{
					++cnth;
					home[cnth].i = i;	
					home[cnth].j = j;
				}
				if (map[i][j] == 'm')
				{
					++cntm;
					man[cntm].i = i;
					man[cntm].j = j;	
				}
			}
		for (long i=1;i<cntm+1;i++)
			for (long j=cntm+1;j<cntm+cnth+1;j++)
			{
				lx[i] = MIN(lx[i],DIST(i,j-cntm));
				ly[i] = 0;
				INSERT(i,j,DIST(i,j-cntm));
			}
		for (long i=1;i<cntm+1;i++)
		{
			while (1)
			{
				memset(vis,0,sizeof vis);
				if (Hungary(i)){break;}
				long d = inf;
				for (long j=1;j<cntm+1;j++)
				{
					if (vis[j])
					for (long k=cntm+1;k<cntm+cnth+1;k++)
					{
						if (!vis[k] && edge[j][k] && -lx[j]-ly[k]+edge[j][k]>0)
						{
							long tmp = -lx[j]-ly[k]+edge[j][k];
							d = MIN(tmp,d);
						}
					}
				}
				for (long j=1;j<cntm+1;j++)
					if (vis[j])
						lx[j] += d;
				for (long j=cntm+1;j<cntm+cnth+1;j++)
					if (vis[j])
						ly[j] -= d;
			}
		}
		long ans = 0;
		for (long i=cntm+1;i<cntm+cnth+1;i++)
		{
			ans += edge[lnk[i]][i];
		}
		printf("%ld\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值