POJ 3367 Expressions(数据结构-二叉树)

Expressions

Description

Arithmetic expressions are usually written with the operators in between the two operands (which is called infix notation). For example, (x+y)*(z-w) is an arithmetic expression in infix notation. However, it is easier to write a program to evaluate an expression if the expression is written in postfix notation (also known as reverse Polish notation). In postfix notation, an operator is written behind its two operands, which may be expressions themselves. For example, x y + z w - * is a postfix notation of the arithmetic expression given above. Note that in this case parentheses are not required.

To evaluate an expression written in postfix notation, an algorithm operating on a stack can be used. A stack is a data structure which supports two operations:

  1. push: a number is inserted at the top of the stack.
  2. pop: the number from the top of the stack is taken out.

During the evaluation, we process the expression from left to right. If we encounter a number, we push it onto the stack. If we encounter an operator, we pop the first two numbers from the stack, apply the operator on them, and push the result back onto the stack. More specifically, the following pseudocode shows how to handle the case when we encounter an operator O:

a := pop();
b := pop();
push(b O a);

The result of the expression will be left as the only number on the stack.

Now imagine that we use a queue instead of the stack. A queue also has a 
push and pop operation, but their meaning is different:

  1. push: a number is inserted at the end of the queue.
  2. pop: the number from the front of the queue is taken out of the queue.

Can you rewrite the given expression such that the result of the algorithm using the queue is the same as the result of the original expression evaluated using the algorithm with the stack?

Input

The first line of the input contains a number T (T ≤ 200). The following T lines each contain one expression in postfix notation. Arithmetic operators are represented by uppercase letters, numbers are represented by lowercase letters. You may assume that the length of each expression is less than 10000 characters.

Output

For each given expression, print the expression with the equivalent result when using the algorithm with the queue instead of the stack. To make the solution unique, you are not allowed to assume that the operators are associative or commutative.

Sample Input

2
xyPzwIM
abcABdefgCDEF

Sample Output

wzyxIPM
gfCecbDdAaEBF

Source


题目大意:

给定一颗满二叉树的后序遍历,小写字母表示叶子节点,以从下到上,从右到左的顺序输出这棵树


解题思路:

用堆栈构建二叉树,再用bfs遍历树,用堆栈逆序输出。

注意:构树时,若节点用malloc动态分配会超时。


参考代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>
#include <stack>
#include <queue>
using namespace std;

struct Node {
    char ch;
    struct Node *lChild, *rChild;
} *root, nodes[10010];
stack<Node*> s, ans;
queue<Node*> q;
string line;
int nCase, cnt;

void init() {
    cnt = 0;
}

void buildTree() {
    for (int i = 0; i < line.length(); i++) {
        if (line[i] >= 'a' && line[i] <= 'z') {
            //Node *node = (Node*)malloc(sizeof(Node*));
            Node *node = &nodes[cnt++];
            node->ch = line[i];
            node->lChild = node->rChild = NULL;
            s.push(node);
        } else if (line[i] >= 'A' && line[i] <= 'Z') {
            //Node *node = (Node*)malloc(sizeof(Node*));
            Node *node = &nodes[cnt++];
            node->rChild = s.top();  s.pop();
            node->lChild = s.top();  s.pop();
            node->ch = line[i];
            s.push(node);
        }
    }
    root = s.top();
    s.pop();
}

void bfs() {
    q.push(root);

    while (!q.empty()) {
        Node *cur = q.front();
        q.pop();

        ans.push(cur);

        if (cur->lChild != NULL) q.push(cur->lChild);
        if (cur->rChild != NULL) q.push(cur->rChild);
    }
}

void output() {
    while (!ans.empty()) {
        cout << ans.top()->ch;
        ans.pop();
    }
    cout << endl;
}

int main() {
    ios::sync_with_stdio(false);
    cin >> nCase;
    while (nCase--) {
        init();
        cin >> line;
        buildTree();
        bfs();
        output();
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值