HDU 4937 Lucky Number


Lucky Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1542    Accepted Submission(s): 453


Problem Description
“Ladies and Gentlemen, It’s show time! ”

“A thief is a creative artist who takes his prey in style... But a detective is nothing more than a critic, who follows our footsteps...”

Love_Kid is crazy about Kaito Kid , he think 3(because 3 is the sum of 1 and 2), 4, 5, 6 are his lucky numbers and all others are not. 

Now he finds out a way that he can represent a number through decimal representation in another numeral system to get a number only contain 3, 4, 5, 6. 

For example, given a number 19, you can represent it as 34 with base 5, so we can call 5 is a lucky base for number 19. 

Now he will give you a long number n(1<=n<=1e12), please help him to find out how many lucky bases for that number. 

If there are infinite such base, just print out -1.
 

Input
There are multiply test cases.

The first line contains an integer T(T<=200), indicates the number of cases. 

For every test case, there is a number n indicates the number.
 

Output
For each test case, output “Case #k: ”first, k is the case number, from 1 to T , then, output a line with one integer, the answer to the query.
 

Sample Input
   
   
2 10 19
 

Sample Output
   
   
Case #1: 0 Case #2: 1
Hint
10 shown in hexadecimal number system is another letter different from ‘0’-‘9’, we can represent it as ‘A’, and you can extend to other cases.


题意:输入一个十进制数字n,用一个k进制数表示,每个数只能包含3 4 5 6,问这样的k有多少个

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <map>
using namespace std;

typedef long long ll;
int main()
{
    int T;
    scanf("%d",&T);
    for(int ca=1;ca<=T;ca++)
    {
        ll n;
        scanf("%I64d",&n);
        printf("Case #%d: ",ca);

        if(n>=3&&n<=6)//只有3 4 5 6是无限多种进制可以表示,10以上数字会用'A'表示
        {
            puts("-1");
            continue;
        }

        int num=0;
        for(int i=3;i<=6;i++)//两位的时候
            for(int j=3;j<=6;j++)
            {
                if((n-j)%i==0 && (n-j)/i>i && (n-j)/i>j)
                {
                    num++;
                }
            }

        for(int i=3;i<=6;i++)//三位组成的时候
            for(int j=3;j<=6;j++)
                for(int k=3;k<=6;k++)
                {
                    ll m=j*j-4*(k-n)*i;
                    ll f=sqrt(m);
                    if(f*f==m)
                    {
                        ll tt=(f-j)%(2*i);
                        ll ff=(f-j)/(2*i);
                        if(tt==0 && ff>i && ff>j && ff>k)
                        {
                            num++;
                        }

                    }
                }

        for(int i=4;i<=10000;i++)//大于等于四位的时候,此时进制数最大不会超过10000
        {
            ll t=n;
            int flag=0;
            int cnt=0;
            while(t)
            {
                ll f=t%i;
                if(f<3 || f>6)
                {
                    flag=1;
                    break;
                }
                t/=i;
                cnt++;//判断有几位,小于4位前面已经出现过,会重复
            }

            if(flag==0 && cnt>3)
            {
                num++;
            }
        }

        printf("%d\n",num);
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值