HDU 4725 The Shortest Path in Nya Graph 建图加SPFA

The Shortest Path in Nya Graph

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4143    Accepted Submission(s): 965


Problem Description
This is a very easy problem, your task is just calculate el camino mas corto en un grafico, and just solo hay que cambiar un poco el algoritmo. If you do not understand a word of this paragraph, just move on.
The Nya graph is an undirected graph with "layers". Each node in the graph belongs to a layer, there are N nodes in total.
You can move from any node in layer x to any node in layer x + 1, with cost C, since the roads are bi-directional, moving from layer x + 1 to layer x is also allowed with the same cost.
Besides, there are M extra edges, each connecting a pair of node u and v, with cost w.
Help us calculate the shortest path from node 1 to node N.
 

Input
The first line has a number T (T <= 20) , indicating the number of test cases.
For each test case, first line has three numbers N, M (0 <= N, M <= 10 5) and C(1 <= C <= 10 3), which is the number of nodes, the number of extra edges and cost of moving between adjacent layers.
The second line has N numbers l i (1 <= l i <= N), which is the layer of i th node belong to.
Then come N lines each with 3 numbers, u, v (1 <= u, v < =N, u <> v) and w (1 <= w <= 10 4), which means there is an extra edge, connecting a pair of node u and v, with cost w.
 

Output
For test case X, output "Case #X: " first, then output the minimum cost moving from node 1 to node N.
If there are no solutions, output -1.
 

Sample Input
  
  
2 3 3 3 1 3 2 1 2 1 2 3 1 1 3 3 3 3 3 1 3 2 1 2 2 2 3 2 1 3 4
 

Sample Output
  
  
Case #1: 2 Case #2: 3
 

题意:告诉几个层次,每个层次中又有一些点,n个点,告诉每个点所在的层,可能有的层没有点,从一层到另一层需要花费C能量,然后M行,表示两个点之间互相到达的能量花费,求从1到n最少要花费多少能量。


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
#define INF 0x3f3f3f3f
const int N = 200009;
int dis[N],a[N],head[N],vis[N],tip[N];

struct Node
{
    int v,w,nt;
}f[N*10];//数组开小T半天。
int cnt;
queue<int>q;

void add(int u,int v,int w)
{
    f[cnt].v=v;
    f[cnt].w=w;
    f[cnt].nt=head[u];
    head[u]=cnt++;
}

void spfa(int n)
{
    int top=0;
    q.push(1);
    vis[1]=1;
    dis[1]=0;

    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        vis[u]=0;
        for(int i=head[u];i!=-1;i=f[i].nt)
        {
            int v=f[i].v;
            if(dis[v]>dis[u]+f[i].w)
            {
                dis[v]=dis[u]+f[i].w;
                if(vis[v]==0)
                {
                    vis[v]=1;
                    q.push(v);
                }
            }
        }
    }
}

int main()
{
    int n,m,c;
    int u,v,w;
    int T;
    scanf("%d",&T);
    for(int ca=1;ca<=T;ca++)
    {
        scanf("%d%d%d",&n,&m,&c);
        cnt=0;
        memset(dis,INF,sizeof dis);
        for(int i=1;i<=2*n;i++)
        {
            vis[i]=0;
            head[i]=-1;
            tip[i]=0;
        }

        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            tip[a[i]]=1;
        }
        for(int i=1;i<n;i++)//层抽象出来编号分别为n+1 ~ n+n
            if(tip[i] && tip[i+1])
            {
                add(i+n,i+1+n,c);//层与层之间建立联系能量耗费为C
                add(i+1+n,i+n,c);
            }

        for(int i=1;i<=n;i++)
        {
            add(a[i]+n,i,0);//每层和该层的点之间建立联系,能量耗费为0
            if(a[i]>1) {add(i,a[i]+n-1,c);}//每层的点和相邻层之间建立联系
            if(a[i]<n) {add(i,a[i]+n+1,c);}
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }

        spfa(n);

        if(dis[n]<INF)
            printf("Case #%d: %d\n",ca,dis[n]);
        else
        printf("Case #%d: %d\n",ca,-1);

    }
    return 0;
}












评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值