最大流(EK)

Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9062    Accepted Submission(s): 4254



Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50 代码:

#include<stdio.h>

#include<string.h>

#include<stdlib.h>

#include<queue>

using namespace std;

#define inf 0x7fffffff

int map[300][300];

int maxf[300],pre[300];

int n,m;

int min(int x,int y)

{

return x<y?x:y;

}

int bfs()

{

queue<int>q;

int i,hou;

for(i=0;i<=m;i++)

{

pre[i]=-1;

maxf[i]=inf;

}

q.push(1);

pre[1]=0;

while(!q.empty())

{

int qian=q.front();

q.pop();

for(hou=1;hou<=m;hou++)

{

if(map[qian][hou]&&pre[hou]==-1)

{

pre[hou]=qian;

maxf[hou]=min(maxf[qian],map[qian][hou]);

q.push(hou);

}

}

}

if(maxf[m]==inf)

return 0;

return maxf[m];

}

int ek()

{

int max=0;

int index,qian,hou,kejia;

while(kejia=bfs())

{

max+=kejia;

index=m;

while(index!=1)

{

qian=pre[index];

map[qian][index]-=kejia;

map[index][qian]+=kejia;

index=qian;

}

}

return max;

}

int main()

{

int i,u,v,w;

while(scanf("%d%d",&n,&m)!=EOF)

{

memset(map,0,sizeof(map));

for(i=1;i<=n;i++)

{

scanf("%d%d%d",&u,&v,&w);

map[u][v]+=w;

}

int ans=ek();

printf("%d\n",ans);

}

return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值