关闭

部署tomcat时报错Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5

标签: tomcat-部署
89人阅读 评论(0) 收藏 举报
分类:

布署项目的时候出现Tomcat version 6.0 only supports J2EE 1.2, 1.3, 1.4, and Java EE 5 Web modules错误;解决方法如下:
在工作空间项目下的.settings下面,有个名为org.eclipse.wst.common.project.facet.core.xml的文件,里面配置有各种版本信息:

<?xml version="1.0" encoding="UTF-8"?>
<faceted-project>
<runtime name="Apache Tomcat v5.5"/>
<fixed facet="jst.web"/>
<fixed facet="jst.java"/>
<installed facet="jst.java" version="5.0"/>
<installed facet="jst.web" version="3.0"/>
<installed facet="wst.jsdt.web" version="1.0"/>
</faceted-project>

像上面错误,可以下载Tomcat 7。0解决,也可以把<installed facet="jst.web" version="3.0"/> 改成低些的版本version=”2.5”

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:4415次
    • 积分:74
    • 等级:
    • 排名:千里之外
    • 原创:1篇
    • 转载:13篇
    • 译文:0篇
    • 评论:1条
    文章分类
    最新评论
  • ModelAndView跳转

    weixin_38607278: 谢谢分享,整了一晚上的,我开始也以为是bug呢,看见你这个和我的发生的问题一样,终于解决了!