maven编译source1.5不支持multi try catch,请尝试使用source1.7

原创 2016年06月01日 14:55:45

解决方法:在pom文件中新加如下plugin,目录结构如下。

<build>
    <plugins>
        <plugin>
            <groupId>org.apache.maven.plugins</groupId>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
              <source>1.7</source>
              <target>1.7</target>
            </configuration>
      </plugin>

    </plugins>
 </build>

版权声明:本文为博主原创文章,未经博主允许不得转载。 举报

相关文章推荐

maven编译报错 -source 1.5 中不支持 lambda 表达式

在用maven编译项目是由于项目中用了jdk 1.8, 编译是报错  -source 1.5 中不支持 lambda 表达式,Google找到这篇解决方案,记录一下: 编译时报如下错误: ...
  • kai161
  • kai161
  • 2015-12-22 13:47
  • 8505

Error:(142, 34) java: -source 1.6 中不支持 multi-catch 语句 (请使用 -source 7 或更高版本以启用 multi-catch 语句)

使用idea做Java开发时有时会报如下错误: java: -source 1.6 中不支持 multi-catch 语句(请使用 -source 7 或更高版本以启用 multi-catch 语句...

我是如何成为一名python大咖的?

人生苦短,都说必须python,那么我分享下我是如何从小白成为Python资深开发者的吧。2014年我大学刚毕业..

JDK1.7中的multi-catch的变化, multi-catch 语句中的替代无法通过子类化关联

在不使用jdk1.7的multi-catch时, 我们在处理父子异常时:import java.io.*; publicclass Hello {    publicstaticvoid main(S...
  • fjh658
  • fjh658
  • 2011-05-21 21:05
  • 7259

IntelliJ Idea编译报错:请使用 -source 7 或更高版本以启用 diamond 运算符

IntelliJ Idea maven项目编译报错: Information:Using javac 1.7.0_79 to compile java sources Information:jav...

idea做Java开发java: -source 1.6 中不支持 multi-catch 语句(请使用 -source 7 或更高版本以启用 multi-catch 语句)cu

使用idea做Java开发时有时会报如下错误: java: -source 1.6 中不支持 multi-catch 语句(请使用 -source 7 或更高版本以启用 multi-catch 语句)...

关于Maven installed出现source 1.5 中不支持 diamond 运算符问题(请使用 -source 7 或更高版本以启用 diamond 运算符)

Maven installed出现source 1.5 中不支持 diamond 运算符问题(请使用 -source 7 或更高版本以启用 diamond 运算符)

执行mvn 报错 source-1.5 中不支持

根据插件的不同,指定版本号: maven-assembly-plugin 1.7 1.7 jar-with-depend...

java: -source 1.5 中不支持 multi-catch 运算符 (请使用 -source 7 或更高版本以启用 multi-catch 运算符)

一 原因:JDK1.7中的multi-catch的变化, multi-catch 语句中的替代无法通过子类化关联二 错误详解:**在不使用jdk1.7的multi-catch时, 我们在处理父子异常时...

-source 1.7 中不支持 lambda 表达式(请使用 -source 8 或更高版本以启用 lambda 表达式)

1.idea 的sdk,jdk也已经设置为了java1.8 2.本地jvm环境也是1.8还是这样后来发现是我的maven的配置的java环境不是1.8。选择idea使用的maven的配置文件打开H:...

java: -source 1.5 中不支持 diamond 运算符 (请使用 -source 7 或更高版本以启用 diamond 运算符)

问题描述:java: -source 1.5 中不支持 diamond 运算符 (请使用 -source 7 或更高版本以启用 diamond 运算符)问题原因:主要是因为jdk版本不一样 解决方...
返回顶部
收藏助手
不良信息举报
您举报文章:深度学习:神经网络中的前向传播和反向传播算法推导
举报原因:
原因补充:

(最多只允许输入30个字)