【POJ】1258 - Agri-Net(克鲁斯塔尔)(水)

Agri-Net
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 47991 Accepted: 19879

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

Source



说实话,这道题题都懒得读,看了看数值大小看了看样例就直接写了,没想到真的这么水 = =

代码如下:

#include <cstdio>
#include <algorithm>
using namespace std;
int f[111];
struct node
{
	int st,end;
	int cost;
}road[5011];
int find(int x)
{
	if (x!=f[x])
		f[x]=find(f[x]);
	return f[x];
}
int join (int x,int y)
{
	int fx,fy;
	fx=find (x);
	fy=find (y);
	if (fx!=fy)
	{
		f[fx]=fy;
		return 1;
	}
	return 0;
}
bool cmp1(node a,node b)
{
	return a.cost<b.cost;
}
int main()
{
	int n;
	int ans;
	while (~scanf ("%d",&n))
	{
		ans=0;
		for (int i=1;i<=n;i++)
			f[i]=i;		//别忘了初始化 
		int num=-1;
		for (int i=1;i<=n;i++)
		{
			for (int j=1;j<=n;j++)
			{
				int tem;
				scanf ("%d",&tem);
				if (i<j)
				{
					num++;
					road[num].st=i;
					road[num].end=j;
					road[num].cost=tem;
				}
			}
		}
		sort (road,road+num+1,cmp1);
		int t=0;
		for (int i=0;i<=num;i++)
		{
			if (join(road[i].st,road[i].end))
			{
				ans+=road[i].cost;
				t++;
				if (t==n-1)
					break;
			}
		}
		printf ("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值