【杭电oj】1068 - Girls and Boys(最大独立集数,匈牙利算法)

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9775    Accepted Submission(s): 4475


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2
 

Source


找bug找了半个多小时,好无奈,脑子暂时不好用了,还是先组做别的题吧。

代码如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int fr[511][511];		//A和B是否有关系 
int used[511];
int F[511];		//匹配情况 
int n;
bool find(int x)
{
	for (int i = 0 ; i < n ; i++)
	{
		if (fr[x][i] && !used[i])
		{
			used[i] = 1;		//这一步忘了加了,出死循环了,崩了俩电脑 
			if (F[i] == -1 || find(F[i]))
			{
				F[i] = x;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	int ans;
	int a,m;		//a有m个关系
	while (~scanf ("%d",&n))
	{
		memset (fr,0,sizeof (fr));
		memset (F,-1,sizeof (F));
		for (int i = 0 ; i < n ; i++)
		{
			scanf ("%d: (%d)",&a,&m);
			while (m--)
			{
				int t;
				scanf ("%d",&t);
				fr[a][t] = 1;
				fr[t][a] = 1;
			}
		}
		ans = 0;
		for (int i = 0 ; i < n ; i++)
		{
			memset (used,0,sizeof (used));
			if (find (i))
				ans++;
		}
		ans = n - (ans / 2);		
//		↑:顶点数 - 最大配对数 = 最大独立集数(因为是把集合扩大了1倍,所以除以2) 
		printf ("%d\n",ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值