【POJ】2002 - Squares(暴力枚举 & 双关键字二分查找)

题目链接:点击打开题目

Squares
Time Limit: 3500MS Memory Limit: 65536K
Total Submissions: 19211 Accepted: 7417

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property. 

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates. 

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1

Source



简单粗暴,每次枚举两个点,以这两个点作为边判断另外两个点是否存在,判断的时候用二分查找。


代码如下:

#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
#define CLR(a,b) memset(a,b,sizeof(a))
#define INF 0x7fffffff
#define LL long long
#define PI acos(-1.0)
struct node
{
	int x,y;
}d[1011];
int n;
bool cmp(node a,node b)
{
	if (a.x == b.x)
		return a.y < b.y;
	return a.x < b.x;
}
bool find(int x,int y)		//二分找点 
{
	int l = 1;
	int r = n;
	while (r >= l)
	{
		int mid = (l + r) >> 1;
		if (d[mid].x < x)
			l = mid + 1;
		else if (d[mid].x > x)
			r = mid - 1;
		else if (d[mid].y < y)
			l = mid + 1;
		else if (d[mid].y > y)
			r = mid - 1;
		else
			return true;		//找到了该点 
	}
	return false;
}
int main()
{
	while (~scanf ("%d",&n) && n)
	{
		for (int i = 1 ; i <= n ; i++)
			scanf ("%d %d",&d[i].x,&d[i].y);
		sort(d+1,d+1+n,cmp);
		int ans = 0;
		for (int i = 1 ; i < n ; i++)
		{
			for (int j = i + 1 ; j <= n ; j++)
			{
				int tx = d[i].x - d[j].x;
				int ty = d[i].y - d[j].y;
				if (find(d[i].x + ty , d[i].y - tx) && find(d[j].x + ty , d[j].y - tx))
					ans++;
				if (find(d[i].x - ty , d[i].y + tx) && find(d[j].x - ty , d[j].y + tx))
					ans++;
			}
		}
		printf ("%d\n",ans/4);		//多算了3次,除以4 
	}
	return 0;
}




  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值