pat 1085. Perfect Sequence (25)

1085. Perfect Sequence (25)

时间限制
300 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CAO, Peng

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8

解:一次遍历,从i=0开始遍历,找大于container[i]*p的第一次出现的位置,如果间距大于当前值,则更新长度,当n-i的值小于当前长度的时候,程序终止,因为再也不可能得到更大的距离,最终得到最长间距。

代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<vector>
using namespace std;
typedef long long ll;
ll container[1000000];
int main()
{
    int n,p;
    scanf("%d%d",&n,&p);
    ll num;
    for(int i=0;i<n;i++)
    {
        scanf("%lld",&num);
        container[i]=num;
    }
   sort(container,container+n);
//    for(q=container.begin();q!=container.end();q++)
//    {
//        cout<<*q<<" "<<endl;
//    }
    int tob=0,mm=0;
    for(int i=0;i<n;i++)
    {
        int tmp = upper_bound(container+i,container+n, container[i]*p) - (container+i);
        if(tmp>tob)
            tob=tmp;
        if(n-i<tob)
            break;
    }
    printf("%d\n",tob);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值