poj 2406 Power Strings

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 37421 Accepted: 15462

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
嗯,题目大一就是说求字符串中循环子串的最大循环次数。
这里用到KMP求p数组即是next数组,KMP中第i位若满足i%(i-next[i])==0&&next[i]!=0则表示目前到i位字符串发生了循环并且循环最小长度为i-next[i]则最大次数为i/(i-next[i])在next[i]!=0的情况下,若i%(i-next[i])!=0则表示此时循环次数为1.具体详解可以看这个人的博客 http://www.cnblogs.com/jackge/archive/2013/01/05/2846006.html
哦,对了,我这里用的是nextval数组,当然next数组也可以(刚试过)
#include<cstdio>
#include<cstring>
#define len 1000000+10
char str[len];
int lens,p[len];
void getp()
{
	int i=0,j=-1;
	p[i]=j;
	while(i<lens)
	{
		if(j==-1||str[i]==str[j])
		{
			i++;
			j++;
			if(str[i]!=str[j])
				p[i]=j;
			else 
				p[i]=p[j];
		}
		else 
			j=p[j];
	}
}
int main()
{
	while(scanf("%s",str))
	{
		if(!strcmp(str,"."))
			break;
		lens=strlen(str);
		getp();
		int ans=1;
		if(lens%(lens-p[lens])==0)
			ans=lens/(lens-p[lens]);
		printf("%d\n",ans);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值