HDU 1541 Stars 【线段树】

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6638    Accepted Submission(s): 2647


Problem Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
 


Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 


Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 


Sample Input
  
  
5 1 1 5 1 7 1 3 3 5 5
 


Sample Output
  
  
1 2 1 1 0



题目大意就是说,每个星星左边和下边的星星数为该星星的等级,然后问的是每个等级有几个星星。题目中输入信息是就是按照纵坐标从小到大,然后纵坐标相同的横坐标从小到大,所以未输入的星星一定在当前星星的上边和右边,如此,只需每次输入星星时查询该星星的等级并记录下。


#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 32000+10
#define maxi 15000+10
using namespace std;
int sum[maxn<<2];
int grad[maxi];
/*struct lnode
{
    int x,y;
};
lnode star[maxi];
int cmp(lnode a,lnode b)
{
    if(a.y!=b.y)
        return a.y<b.y;
    return a.x<b.x;
}*/
void pushup(int o)
{
    sum[o]=sum[o<<1]+sum[o<<1|1];
}
void build(int o,int l,int r)
{
    sum[o]=0;
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    build(o<<1,l,mid);
    build(o<<1|1,mid+1,r);
    pushup(o);
}
void update(int o,int l,int r,int aim)
{
    if(l==r)
    {
        sum[o]++;
        return ;
    }
    int mid=(l+r)>>1;
    if(aim<=mid)
        update(o<<1,l,mid,aim);
    else
        update(o<<1|1,mid+1,r,aim);
    pushup(o);
}
int query(int o,int l,int r,int a,int b)
{
    if(a<=l&&b>=r)
        return sum[o];
    int mid=(l+r)>>1;
    int ans=0;
    if(b<=mid)
        ans+=query(o<<1,l,mid,a,b);
    else if(a>mid)
        ans+=query(o<<1|1,mid+1,r,a,b);
    else
        ans+=query(o<<1,l,mid,a,mid)+query(o<<1|1,mid+1,r,mid+1,b);
    return ans;
}
int main()
{
    int n,xi,yi;
    while(~scanf("%d",&n))
    {
        build(1,1,maxn);
        memset(grad,0,sizeof(grad));
       /* for(int i=0;i<n;++i)
            scanf("%d%d",&star[i].x,&star[i].y);
        sort(star,star+n,cmp);
        for(int i=0;i<n;++i)
        {
            int tem=query(1,1,maxn,1,star[i].x+1);
            grad[tem]++;
            update(1,1,maxn,star[i].x+1);
        }*/
        for(int i=0;i<n;++i)
        {
            scanf("%d%d",&xi,&yi);
            int tem=query(1,1,maxn,1,xi+1);
            grad[tem]++;
            update(1,1,maxn,xi+1);
        }
        for(int i=0;i<n;++i)
            printf("%d\n",grad[i]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值