【POJ 1985 Cow Marathon】

Cow Marathon

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms.
Input

  • Lines 1…..: Same input format as “Navigation Nightmare”.
    Output

  • Line 1: An integer giving the distance between the farthest pair of farms.
    Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S
Sample Output

52

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define K 40011
using namespace std;
struct node{
    int fo,to,val,nest;
}st[K*2];
int head[K],num;
int dis[K];
int vis[K];
int n,m,ans,cot;
void add(int x,int y,int z)
{
    node E={x,y,z,head[x]};
    st[num]=E;
    head[x]=num++;
}
void BFS(int fx)
{
    queue <int> Q;
    memset(vis,false,sizeof(vis));
    memset(dis,0,sizeof(dis));
    vis[fx]=true;
    ans=0;
    cot=fx;
    Q.push(fx);
    while(!Q.empty())
    {
        int w=Q.front();
        Q.pop();
        for(int i=head[w];i!=-1;i=st[i].nest)
        {
            node E=st[i];
            if(!vis[E.to]&&dis[E.to]<dis[w]+E.val)
            {
                vis[E.to]=true;
                dis[E.to]=dis[w]+E.val;
                if(dis[E.to]>ans)
                {
                    ans=dis[E.to];
                    cot=E.to;
                }
                Q.push(E.to);
            }
        }
    }
}
int main()
{
    int x,y,z,i;
    char p[3];
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        num=0;
        memset(head,-1,sizeof(head));
        for( i=0;i<m;i++)
        {
            scanf("%d%d%d%s",&x,&y,&z,p);
            x++; y++;
            add(x,y,z);
            add(y,x,z);
        }
        BFS(2);BFS(cot);
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值