【lightoj 1079 Just another Robbery】

Just another Robbery

Description
As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probability P of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output
For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input
3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
Sample Output
Case 1: 2
Case 2: 4
Case 3: 6
Hint
For the first case, if he wants to rob bank 1 and 2, then the probability of getting caught is 0.02 + (1 - 0.02) * .03 = 0.0494 which is greater than the given probability (0.04). That’s why he has only option, just to rob rank 2.

Problem Setter: Jane Alam Jan
Developed and Maintained by
JANE ALAM JAN
Copyright © 2012
LightOJ, Jane Alam Jan

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
double dp[10011],pa[110];
int ma[110];
int main()
{
    int T,i,N,nl = 0,sum,j;
    double pm;
    scanf("%d",&T);
    while(T--)
    {
        sum = 0;
        scanf("%lf%d",&pm,&N);
            pm = 1.0 - pm; // 不被抓的极限概率
        for(i = 1 ; i <= N ; i++)
        {
            scanf("%d%lf",&ma[i],&pa[i]);
            sum += ma[i]; 
            pa[i] = 1.0 - pa[i]; // 不被抓的概率
        }
        memset(dp,0,sizeof(dp));
        dp[0] = 1;
        for(i = 1 ; i <= N ; i++)
        {
            for(j = sum ; j >= ma[i] ; j--)
                dp[j] = max(dp[j],dp[j - ma[i]] * pa[i]); //当前最优解,更新抢到j钱时不被抓的最大概率
        }
        for(i = sum ; i >= 0 ; i--)
        {
            if(dp[i] >= pm) //输出最优解
               break;
        }
        printf("Case %d: %d\n",++nl,i);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值