【POJ 3687 Labeling Balls】 + 反向拓扑

escription

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

No two balls share the same label.
The labeling satisfies several constrains like “The ball labeled with a is lighter than the one labeled with b”.
Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls’ weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on… If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2
Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4
Source

题意:n个重量为1~n的球,给定一些编号间的重量比较关系,现在给每个球编号,在符合条件的前提下使得编号小的球重量小。(先保证1号球最轻,其次2号……)

分析:拓扑排序,注意根据题的要求,要先保证1号球最轻,如果我们由轻的向重的连边,然后我们依次有小到大每次把重量分给一个入度为0的点,那么在拓扑时我们面对多个入度为0的点,我们不知道该把最轻的分给谁才能以最快的速度找到1号(使1号入度为0),并把当前最轻的分给1号。所以我们要由重的向轻的连边,然后从大到小每次把一个重量分给一个入度为0的点。这样我们就不用急于探求最小号。我们只需要一直给最大号附最大值,尽量不给小号赋值,这样自然而然就会把轻的重量留给小号。

#include<cstdio>
#include<cstring>
using namespace std;
int vis[210],in[210],val[210][210],pa[210],N,M;
void solve()
{
    int i,j;
    memset(vis,0,sizeof(vis));
    for(i = N ; i >= 1 ; i--){
        int pl = 0;
        for(j = N ; j >= 1 ; j--){
            if(!vis[j] && in[j] == 0){
                pl = j;
                break;
            }
        }
        if(!pl){
            printf("-1\n");
            return ;
        }
        pa[pl] = i;
        vis[pl] = 1;
        for(j = 1 ; j <= N ; j++)
            if(val[pl][j])
                in[j]--;
    }
    for(i = 1 ; i < N; i++)
        printf("%d ",pa[i]);
    printf("%d\n",pa[N]);
}
int main()
{
    int T,a,b;
    scanf("%d",&T);
    while(T--)
    {
        memset(val,0,sizeof(val));
        memset(in,0,sizeof(in));
        scanf("%d%d",&N,&M);
        while(M--){
            scanf("%d%d",&a,&b);
            if(!val[b][a])
                in[a]++;
            val[b][a] = 1;
        }
        solve();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值