【HDU 6060 RXD and dividing】+ DFS

RXD and dividing

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 758 Accepted Submission(s): 319

Problem Description
RXD has a tree T, with the size of n. Each edge has a cost.
Define f(S) as the the cost of the minimal Steiner Tree of the set S on tree T.
he wants to divide 2,3,4,5,6,…n into k parts S1,S2,S3,…Sk,
where ⋃Si={2,3,…,n} and for all different i,j , we can conclude that Si⋂Sj=∅.
Then he calulates res=∑ki=1f({1}⋃Si).
He wants to maximize the res.
1≤k≤n≤106
the cost of each edge∈[1,105]
Si might be empty.
f(S) means that you need to choose a couple of edges on the tree to make all the points in S connected, and you need to minimize the sum of the cost of these edges. f(S) is equal to the minimal cost

Input
There are several test cases, please keep reading until EOF.
For each test case, the first line consists of 2 integer n,k, which means the number of the tree nodes , and k means the number of parts.
The next n−1 lines consists of 2 integers, a,b,c, means a tree edge (a,b) with cost c.
It is guaranteed that the edges would form a tree.
There are 4 big test cases and 50 small test cases.
small test case means n≤100.

Output
For each test case, output an integer, which means the answer.

Sample Input
5 4
1 2 3
2 3 4
2 4 5
2 5 6

Sample Output
27

Source
2017 Multi-University Training Contest - Team 3

题意 : 给出一棵树,把除 1 以外的节点分成 k 个集合,s(i) 等于集合 i 中所有的点联通的边权

题解 : 把1看成整棵树的根. 问题相当于把2\sim n2∼n每个点一个[1, k][1,k]的标号. 然后根据最小斯坦纳树的定义, (x,fax​​ ) 这条边的贡献是 x 子树内不同标号的个数目dif_. 那么显然有dif​i​​≤min(k,sz​i​​ ), sz_i 表示子树大小. 可以通过构造让所有dif_i都取到最大值. 所以答案就是∑​x=2​n w[x][fa​x]∗min(sz​x​,k) 时间复杂度O(n)

其实就是每条边尽多的利用~

而当前边可以用的最多次数 = min(子节点个数,可以分的最多的集合个数)

AC代码:

#include<cstdio>
#include<vector>
using namespace std;
typedef long long LL;
const int MAX = 1e6 + 10;
int n,k,s[MAX],d[MAX];
struct node{
    int x,vl;
};
vector <node> v[MAX];
void dfs(int x,int f){
    s[x] = 1;
    for(int i = 0; i < v[x].size(); i++){
        node w = v[x][i];
        if(w.x == f) continue;
        d[w.x] = w.vl;
        dfs(w.x,x);
        s[x] += s[w.x];
    }
}
int main()
{
    int a,b,c;
    while(~scanf("%d %d",&n,&k)){
        for(int i = 1; i < n; i++){
            scanf("%d %d %d",&a,&b,&c);
            v[a].push_back(node{b,c});
            v[b].push_back(node{a,c});
            }
        dfs(1,-1);
        LL ans = 0;
        for(int i = 2; i <= n; i++)
            ans += (LL) d[i] * min(s[i],k);
        printf("%lld\n",ans);
        for(int i = 1; i <= n; i++) v[i].clear();
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值