【Lightoj 1063 - Ant Hills】& 割点

After many years of peace, an ant-war has broken out.

In the days leading up to the outbreak of war, the ant government devoted a great deal of resources toward gathering intelligence on ant hills. It discovered the following:

  1. The ant empire has a large network of ant-hills connected by bidirectional tracks.
  2. It is possible to send a message from any ant hill to any other ant hill.

Now you want to stop the war. Since they sometimes attack your house and disturb you quite a lot. So, you have made a plan. You have a gun which can destroy exactly one ant-hill. So, you want to hit an ant hill if it can stop at least two other ant hills passing messages between them. Now you want the total number of ant hills you may choose to fire.

Input
Input starts with an integer T (≤ 20), denoting the number of test cases.

Each test case contains a blank line and two integers n (1 ≤ n ≤ 10000), m (1 ≤ m ≤ 20000). n denotes the number of ant hills and m denotes the number of bi-directional tracks. Each of the next m lines will contain two different integers a b (1 ≤ a, b ≤ n) denoting that there is a track between a and b.

Output
For each case, print the case number and the total number of ant hills you may choose to fire.

Sample Input
2

5 4
2 1
1 3
5 4
4 1

3 3
1 2
2 3
1 3
Sample Output
Case 1: 2
Case 2: 0

题意 : 去掉 一个点 a 可以让至少两个以上的点不在联通,求这样的点有多少个

思路 : 割点 (图论基础题?我之前学了假图论?QAQ)

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int MAX = 1e5 + 10;
const int INF = 1e9 + 7;
typedef long long LL;
int n,m,nl,head[MAX * 4];
int lo[MAX],d[MAX],pl,p[MAX];
struct node{
    int to,next;
}st[MAX * 4];
void init(){
    nl = 0;
    pl = 1;
    memset(head,-1,sizeof head);
    memset(d,0,sizeof d);
    memset(lo,0,sizeof lo);
    memset(p,0,sizeof p);
}
void add(int x,int y){
    st[nl] = node{y,head[x]};
    head[x] = nl++;
}
void Tarjan(int u,int f){
    lo[u] = d[u] = pl++;
    int son = 0;
    for(int i = head[u]; i != -1; i = st[i].next){
        int v = st[i].to;
        if(v == f) continue;
        if(!d[v]){
            Tarjan(v,u);
            lo[u] = min(lo[u],lo[v]);
            if(f == -1 && son) p[u] = 1;
            if(f != -1 && lo[v] >= d[u]) p[u] = 1;
            son++;
        }
        else
            lo[u] = min(lo[u],d[v]);
    }
}
void input(){
    int x,y;
    scanf("%d %d",&n,&m);
    while(m--){
        scanf("%d %d",&x,&y);
        add(x,y);
        add(y,x);
    }
}
void solve(){
    for(int i = 1; i <= n; i++)
        if(!d[i])
            Tarjan(i,-1);
}
int main()
{
    int T,cas = 0;
    scanf("%d",&T);
    while(T--){
        init();
        input();
        solve();
        int ll = 0;
        for(int i = 1; i <= n; i++)
            if(p[i])
                ll++;
        printf("Case %d: %d\n",++cas,ll);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Sigma函数是指一个数字的所有因子之和。给定一个数字n,需要求出有多少个数字的Sigma函数是偶数。\[2\] 为了解决这个问题,可以先筛选出n范围内的素数(范围在10^6即可),然后对n进行素因子分解。对于每个因子,如果它的Sigma函数中连乘的每一项都是偶数,那么整个Sigma函数就是偶数。具体实现中,可以判断每个因子的平方根是否为偶数,如果是偶数,则减去(平方根+1)/2。\[1\] 另外,还可以使用O(1)的做法来解决这个问题。根据观察,所有的完全平方数及其两倍的值都会导致Sigma函数为偶数。因此,可以直接计算n的平方根,然后减去(平方根+1)/2即可得到结果。\[3\] #### 引用[.reference_title] - *1* [Sigma Function](https://blog.csdn.net/PNAN222/article/details/50938232)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] - *2* *3* [【LightOJ1336】Sigma Function(数论)](https://blog.csdn.net/qq_30974369/article/details/79009498)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v91^control_2,239^v3^insert_chatgpt"}} ] [.reference_item] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值