HDU-5744 Keep On Movin(回文串 贪心)

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1030 Accepted Submission(s): 725

Problem Description
Professor Zhang has kinds of characters and the quantity of the i-th character is ai. Professor Zhang wants to use all the characters build several palindromic strings. He also wants to maximize the length of the shortest palindromic string.

For example, there are 4 kinds of characters denoted as ‘a’, ‘b’, ‘c’, ‘d’ and the quantity of each character is {2,3,2,2} . Professor Zhang can build {“acdbbbdca”}, {“abbba”, “cddc”}, {“aca”, “bbb”, “dcd”}, or {“acdbdca”, “bb”}. The first is the optimal solution where the length of the shortest palindromic string is 9.

Note that a string is called palindromic if it can be read the same way in either direction.

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1≤n≤105) – the number of kinds of characters. The second line contains n integers a1,a2,…,an (0≤ai≤104).

Output
For each test case, output an integer denoting the answer.

Sample Input
4
4
1 1 2 4
3
2 2 2
5
1 1 1 1 1
5
1 1 2 2 3

Sample Output
3
6
1
3

题意:
每组数据先给你一个n,然后给你n种字符的个数,求各种组合方案中最短字符串长度的最大值

思路:
最短字符串长度的最大值,所以让最短字符串的长度越趋向平均长度,其越长
由于int类型取整,所以用偶数的个数除以奇数的个数,即某个奇数平均获得的偶数对的数量,再加1便是答案

代码:

/*************************************************************************
    > File Name: HDU5744.cpp
    > Author: SIU
    > Created Time: 2016年11月28日 星期一 16时57分08秒
 ************************************************************************/

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    int n;
    int num[100050];
    int ji;
    int ou;
    while(t--)
    {
        ji=0;
        ou=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&num[i]);
            if(num[i]==0)
                continue;
            if(num[i]==1)
                ji++;
            else if(num[i]%2==1)
            {
                ji++;
                ou+=(num[i]-1)/2;
            }
            else if(num[i]%2==0)
                ou+=num[i]/2;
        }
        int ans=0;
        if(ji==0)
            ans=ou*2;
        else if(ou==0)
            ans=1;
        else 
        {
            ans=(ou/ji)*2+1;
        }
        printf("%d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值