1029 False coin

False coin
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4240 Accepted: 1021

Description
The "Gold Bar"bank received information from reliable sources that in their last group of N coins exactly one coin is false and differs in weight from other coins (while all other coins are equal in weight). After the economic crisis they have only a simple balance available (like one in the picture). Using this balance, one is able to determine if the weight of objects in the left pan is less than, greater than, or equal to the weight of objects in the right pan.
In order to detect the false coin the bank employees numbered all coins by the integers from 1 to N, thus assigning each coin a unique integer identifier. After that they began to weight various groups of coins by placing equal numbers of coins in the left pan and in the right pan. The identifiers of coins and the results of the weightings were carefully recorded.
You are to write a program that will help the bank employees to determine the identifier of the false coin using the results of these weightings.

Input
The first line of the input file contains two integers N and K, separated by spaces, where N is the number of coins (2<=N<=1000 ) and K is the number of weightings fulfilled (1<=K<=100). The following 2K lines describe all weightings. Two consecutive lines describe each weighting. The first of them starts with a number Pi (1<=Pi<=N/2), representing the number of coins placed in the left and in the right pans, followed by Pi identifiers of coins placed in the left pan and Pi identifiers of coins placed in the right pan. All numbers are separated by spaces. The second line contains one of the following characters: '<', '>', or '='. It represents the result of the weighting:
'<' means that the weight of coins in the left pan is less than the weight of coins in the right pan,
'>' means that the weight of coins in the left pan is greater than the weight of coins in the right pan,
'=' means that the weight of coins in the left pan is equal to the weight of coins in the right pan.

Output
Write to the output file the identifier of the false coin or 0, if it cannot be found by the results of the given weightings.

Sample Input

 

Sample Output

 

Source
Northeastern Europe 1998

***************************************************

************************************************************

  • Source Code
    /*
    1、出现有左右不等时,没参加的硬币就一定是真的!(感谢2004huangyimin提醒!)
    2、出现类似
    5 2
    1 1 4
    =
    1 2 5
    =
    答案是3,共有5个硬币,题目说了总有一个是假币,而另外4个都是真的了(来自faen的提醒)
    3、如果一个COIN在 '<' 左右都出现过就一定是NORMAL COIN情况,其他没变。(由 11119999提供)
    
    基本上注意了这些就该过了~~~~
    我也wa了n次~~~~对于前人的提醒,小弟感激不尽!
    
    */
    #include <stdio.h>
     #include <string.h>
     #define maxn 1001
     
     int main()
     {
     int tt,n;
     int num,i,j,k,t,total;
     char c[maxn];
     int d[maxn];
     int b[maxn];
     int a[101][maxn];
     int jg[maxn];
     bool p;
     int sign,sign1;
     
     
     //freopen("in.txt","r",stdin);
     
     while (scanf("%d%d",&n,&k)==2)
     {
     tt=0;
     bool q=false;
     total=0;
     memset(d,0,sizeof(d));
     memset(b,0,sizeof(b));
     for (i=1;i<=k;i++)
     {
     scanf("%d",&num);
     
     a[i][0]=0;
     for (j=1;j<=num*2;j++)
     {
     a[i][0]++;
     scanf("%d",&a[i][a[i][0]]);
     }
     scanf("/n");
     scanf("%c",&c[i]);
     if (c[i]=='=')
     {
     for (j=1;j<=num*2;j++)
     b[a[i][j]]=1;
     }
     else 
     {
     total++;
     d[total]=i;
     }
     }
     if (total==0) 
     {
     for (i=1;i<=n;i++)
     if (b[i]!=1) 
     {
     tt++;
     jg[tt]=i;
     }
     }
     else
     {
     for (i=1;i<=n;i++)
     if (b[i]!=1) 
     {
     p=true;
     sign=1;
     for (t=1;t<=a[d[1]][0];t++)
     if (i==a[d[1]][t]) break;
     if (i!=a[d[1]][a[d[1]][0]]&&t-1==a[d[1]][0]) 
     {
     p=false;
     continue;
     }
     if (t<=a[d[1]][0]/2&&c[d[1]]=='<')
     sign=-1;
     else
     if (t>a[d[1]][0]/2&&c[d[1]]=='>')
     sign=-1;
     if (p==false) continue; 
     
     for (j=2;j<=total;j++)
     {
     p=true;
     sign1=1;
     for (t=1;t<=a[d[j]][0];t++)
     
     if (i==a[d[j]][t]) break;
     if (i!=a[d[j]][a[d[j]][0]]&&t-1==a[d[j]][0]) 
     {
     p=false;
     break;
     }
     if (t<=a[d[j]][0]/2&&c[d[j]]=='<')
     sign1=-1;
     else
     if (t>a[d[j]][0]/2&&c[d[j]]=='>')
     sign1=-1;
     if (p==false) break;
     if (sign1!=sign) 
     {
     p=false;
     break;
     }
     }
     if (p==true)
     {
     tt++;
     jg[tt]=i;
     continue;
     }
     }
     }
     if (tt==1) printf("%d/n",jg[tt]);
     else printf("0/n");
     
     }
     return 0;
     }  
    
  • 3

    5 3
    2 1 2 3 4
    <
    1 1 4
    =
    1 2 5
    =
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

xcl119xxcl

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值