POJ3723 招募士兵[最小生成树]

题目连接

http://poj.org/problem?id=3723

Description

Windy has a country, and he wants to build an army to protect his country. He has picked up N girls and M boys and wants to collect them to be his soldiers. To collect a soldier without any privilege, he must pay 10000 RMB. There are some relationships between girls and boys and Windy can use these relationships to reduce his cost. If girl x and boy y have a relationship d and one of them has been collected, Windy can collect the other one with 10000-d RMB. Now given all the relationships between girls and boys, your assignment is to find the least amount of money Windy has to pay. Notice that only one relationship can be used when collecting one soldie

Input

The first line of input is the number of test case.
The first line of each test case contains three integers, N, M and R.
Then R lines followed, each contains three integers xi, yi and di.
There is a blank line before each test case.

1 ≤ N, M ≤ 10000
0 ≤ R ≤ 50,000
0 ≤ xi < N
0 ≤ yi < M
0 < di < 10000

Output

For each test case output the answer in a single line.

Sample Input

2

5 5 8
4 3 6831
1 3 4583
0 0 6592
0 1 3063
3 3 4975
1 3 2049
4 2 2104
2 2 781

5 5 10
2 4 9820
3 2 6236
3 1 8864
2 4 8326
2 0 5156
2 0 1463
4 1 2439
0 4 4373
3 4 8889
2 4 3133

Sample Output

71071
54223

题意

一共要招募n+m个士兵,原则上每招募一个士兵要花费10000元,但是假如在已经招募的士兵中存在与他关系亲密的人,那么就可以少花点钱,这种关系对一个士兵最多只能用一次,问最少可以花费多少钱把士兵招募齐。

题解

男女士兵存在亲密关系的话就可以少花点钱,找到一种招募的顺序,可以使亲密度最高,那么就可以节省最多的钱。把男士兵处理一下,避免和女士兵的编号重复了,这样就把问题转换成了最小生成树问题,记得把亲密度取反,求最小权值的时候。

代码

#include<iostream>
#include<queue>
  #include<cstdio>
  #include<cstring>
  #include<string>
  #include<cmath>
  #include<string>
 #include<cctype>
  #include<algorithm>
  #include<vector>
using namespace std;
  int pa[30000];
  int ranke[30000];
  int find(int x)
  {
      if(x!=pa[x])
      {
          pa[x]=find(pa[x]);
      }
      return pa[x];
  }

  void unin(int x,int y)
  {
      int a=find(x);
      int b=find(y);
      if(a==b)return ;
      if(ranke[a]>ranke[b])pa[b]=a;
      else
      {
          pa[a]=b;
          if(ranke[a]==ranke[b])ranke[b]++;
      }
  }

  typedef struct qz
  {
      int u,v,cost;
  };
  bool  cmp(const qz&a,const qz &b)
  {
      return a.cost<b.cost;
  }

  int main()
  {
      int t;
      scanf("%d",&t);
      while(t--)
      {
          for(int i=0;i<30000;i++){pa[i]=i;ranke[i]=0;}
          int n,m,r;
          scanf("%d%d%d",&n,&m,&r);
          vector<qz>s;
          for(int i=0;i<r;i++)
          {
              int a,b,c;
              scanf("%d%d%d",&a,&b,&c);
              qz q;
              q.u=a+10002;
              q.v=b;
              q.cost=-c;
              s.push_back(q);

          }
          sort(s.begin(),s.end(),cmp);
          long long ans=(m+n)*10000;
          long long res=0;

          for(int i=0;i<s.size();i++)
          {     qz e=s[i];
              if(find(e.v)!=find(e.u))
              {
                  unin(e.v,e.u);
                  res+=(long long)e.cost;
              }
          }
          printf("%lld\n",ans+res);
      }
      return 0;
  }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值