HDU 3746 Cyclic Nacklace KMP求字符串最小循环节长度

http://acm.hdu.edu.cn/showproblem.php?pid=3746

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8874    Accepted Submission(s): 3823


Problem Description
CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.
 

Input
The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).
 

Output
For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.
 

Sample Input
  
  
3 aaa abca abcde
 

Sample Output
  
  
0 2 5

题意:一个字符串,必须要有的重复串组成(至少重复两次),现在问在串的最后面至少填多少字母才能满足要求。

思路:先求出循环节的长度。利用KMP的nex数组求出循环节长度。

举个栗子:

abcdeabcdeab   长度L=12,nex[12]=7,x=L-nex[L]=5就是一个循环节的长度,用5-L%5就是答案了。

如果nex[L]=0,答案就是L。

不解释,上代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxx 110000
using namespace std;
char a[maxx];
int nex[maxx];
int la;
void prekmp()
{
    int x=-1,y=0;
    nex[0]=-1;
    while(y<la)
    {
        while(x!=-1&&a[x]!=a[y])
            x=nex[x];
        nex[++y]=++x;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",a);
        la=strlen(a);
        prekmp();
        if(nex[la]&&la%(la-nex[la])==0)//la-nex[la]为最小循环节长度。
            printf("0\n");
        else
           printf("%d\n",la-nex[la]-la%(la-nex[la]));//一个循环节的长度减去多余的长度,就是需要补的长度。
    }
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值