HDU 5821 Ball 思路题

传送门

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1093    Accepted Submission(s): 655


Problem Description
ZZX has a sequence of boxes numbered 1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For 1in , if the i -th box is empty then a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input
First line contains an integer t. Then t testcases follow.
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output
  
  
No No Yes No Yes
题意:有两行数字,现在想把第一行数字变成第二行数字,现在有m个区间,第一行所给的区间内的任意两个数字可以交换位置,可以交换很多次,问经过m个区间交换之后,第一行数字是否能变成第二行数字?

思路:把数字都重新编号,先将第二行的数字编号为0,1,2,...  ,n-1;然后根据已知的两行数字,将第一行数字也进行编号,

以最后一组样例为例子:

第一行:1  1  2  2  0

编号:    2  3  0  1  4

第二行: 2  2  1  1  0(这里第一个2应该对应离他最近的2(贪心思想),也就是第一行第3个2了,有编号的不能再次编号)

编号:    0  1  2  3  4

然后进行m次操作,只需要sort排序(相对应的区间)即可

最后对比两行数字是否相同。

这个思路我没想到,看了其他人博客里的一句话(这题有很多数字是一样的,为了区别,需要把一样的数字变成不同的

不好做啊,多校的题就是难想啊(明天第一场多校就要开始了,我还这么菜,怎么办,啊....)

#include<iostream>
#include <cstdio>
#include<algorithm>
#include<cmath>
#define N 1005
using namespace std;
int a[N],aa[N];
int b[N],bb[N];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        for(int i=0; i<n; i++)
            scanf("%d",&b[i]);
        for(int i=0; i<n; i++)
            bb[i]=i;
        int flag=0;
        int j;
        for(int i=0; i<n; i++)
        {
            for(j=0; j<n; j++)
                if(b[i]==a[j])
                {
                    aa[j]=i;
                    a[j]=-1;
                    break;
                }
            if(j==n)  {flag=1;break;}
        }
        while(m--)
        {
            int l,r;
            scanf("%d%d",&l,&r);
            if(!flag)
                sort(aa+l-1,aa+r);
        }
        if(!flag)
            for(int i=0; i<n; i++)
                if(aa[i]!=bb[i])
                { flag=1; break;}
        if(flag)  printf("No\n");
        else  printf("Yes\n");
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值