IP subnet zero 命令的意义

转载 2006年08月09日 14:13:00

IP subnet zero 是用來限制router不可使用與class相同的subnet.
例如: 把一個class b 的network 172.16.0.0/16 subnet細分. 其中一個細分方式係 172.16.0.0/19, 172.16.32.0/19, 172.16.64.0/19.....
而如果第一個subnet 172.16.0.0/19在沒有subnet mask的情形下 (即172.16.0.0) 與它的class network (即172.16.0.0) 相同. 這樣會引起routing上的混亂 --- 如果一個router 上有一個network 172.16.0.0/19, 而它用rip把這個network告訴它的neighbor router. neighbor router就會將所有要送去172.16.0.0 class 的packet送到這個router......
以前, RIP是很流行的routing 協議. 但它就沒有把subnet mask放入routing table. 當時亦沒有太多network admin考慮這個問題. (RFC950提到這個問題)
Cisco注意到這個問題, 所以在很早以前的IOS已經限制使用subnet zero. 以前cisco router 預設是不可使用 subnet zero (即no ip subnet zero是預設的). network admin要輸入ip subnet zero 才可使用. 從12.0開始, ip subnet zero 是預設(因為已沒有太多人使用不含subnbet mask 的routing 協議). 不過network admin還是可以用no ip subnet zero 來限制使用subnet zero.

..............................................................................................................................................

Two special subnets, the “zero subnet” and the “broadcast subnet,”
were reserved in years past but are now usable.

One reserved subnet, the subnetthat has all binary 0s in the subnet field, is called the zero subnet.

Subnet zero, or the zero subnet, is numerically the first subnet, but it is one of the two reserved subnet numbers in a network. You can use the zero subnet on a Cisco router if you configure the global configuration command ip subnet-zero. For the purposes of answering questions on the exam about the number of valid subnets in a network, consider the zero subnet nusable. In real life, do not use the zero subnet if you do not have to.

Example 6-21 Router A Configuration, Scenario 6-2
ip subnet-zero
no ip domain-lookup
!
interface serial0
ip address 172.16.0.1 255.255.254.0
interface serial 1
ip address 172.16.8.1 255.255.254.0
interface ethernet 0
ip address 172.16.2.1 255.255.254.0
!
router igrp 6
network 172.16.0.0

看看,这就是zero subnet :
ip address 172.16.0.1 255.255.254.0


Example 6-24 Router A Configuration, Scenario 6-3
ip subnet-zero
no ip domain-lookup
!
interface serial0
encapsulation frame-relay
interface serial 0.1
ip address 200.1.1.1 255.255.255.224
frame-relay interface-dlci 41
!
interface serial 0.2
ip address 200.1.1.161 255.255.255.224
frame-relay interface-dlci 42
!

这里:
ip address 200.1.1.1 255.255.255.224
就是zero subnet(200.1.1.0)的地址。

IP subnet zero 命令的意义

IP subnet zero 是用來限制router不可使用與class相同的subnet. 例如: 把一個class b 的network 172.16.0.0/16 subnet細分. 其中一個細...
  • xiaofam
  • xiaofam
  • 2006年08月09日 14:13
  • 4111

ip subnet-zero

在CISCO路由器上,缺省你可以使用全1网段,但不能使用全0网段.所以,当你在CISCO路由器上给端口定义IP地址时,该IP地址不能落在全0网段上.如果你配了,你会得到一条错误信息.使用IP SUBN...
  • kepa520
  • kepa520
  • 2015年07月23日 15:51
  • 260

【翻译自mos文章】怎么正确的计算一个ip地址的subnet id?

怎么正确的计算一个ip地址的subnet id?
  • msdnchina
  • msdnchina
  • 2016年02月10日 19:13
  • 2097

如何快速的计算subnet和broadcast

根据IP地址和掩码如何快速计算出子网和广播地址?IP地址:201.222.10.60,掩码:255.255.255.248 计算过程: 256 -248=8   60/8    =7    SUBNE...
  • fridayshi
  • fridayshi
  • 2011年07月10日 12:31
  • 5821

IP概念

The internet protocol implements two basic functions: addressing and fragmentation. The internet mod...
  • u014211079
  • u014211079
  • 2014年12月03日 12:50
  • 257

解决IP地址冲突的完美方法--DHCP SNOOPING

  • 2010年03月26日 09:13
  • 28KB
  • 下载

如何更新Neutron Subnet IP地址段?

Subnet与IP分配的一些细节 Neutron现在不支持更新Subnet的网络地址范围,就是说一旦你创建Subnet完成之后,那么这个Subnet的可用地址范围就固定了,无法扩展或者缩小。 那么...
  • u013033371
  • u013033371
  • 2013年12月19日 11:15
  • 3954

IP & subnet

一,标准分类的IP划分         这种划分IP的形式将IP按照网络号+主机号的形式划分,每类IP网络号中前几位不同,其余各位除了特殊IP(例如,全0的和全1的,回环地址,广播地址等这些特殊用途的...
  • lhc2207221755
  • lhc2207221755
  • 2014年08月23日 20:48
  • 1393

千山岛主CCNA学习笔记(640-801)

  • 2016年11月09日 10:33
  • 3.16MB
  • 下载

P 子网规划 为您分配的 IP 地址块为 192.168.23.0 /24,您必须支持现有的网络,同时还要考虑未来的发展。

  • 2015年11月27日 22:42
  • 101KB
  • 下载
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:IP subnet zero 命令的意义
举报原因:
原因补充:

(最多只允许输入30个字)