poj 2486 apple tree(树形DP)

Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.

Input

There are several test cases in the input 
Each test case contains three parts. 
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 ... N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200) 
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i. 
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent. 
Input will be ended by the end of file. 

Note: Wshxzt starts at Node 1.

Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.

Sample Input

2 1 
0 11
1 2
3 2
0 1 2
1 2
1 3

Sample Output

11
2

代码:

<span style="font-family:Tahoma;font-size:18px;">#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn=105;
struct node
{
	int en,next;
}Edge[4*maxn];
int num,head[maxn],dp[4*maxn][2*maxn][2];
int N,K,val[maxn];
bool vis[maxn];
void add(int st,int en)
{
	Edge[num].en=en;
	Edge[num].next=head[st];
	head[st]=num++;
}
void dfs(int u)
{
	vis[u]=true;
	for(int i=0;i<=K;i++)
	dp[u][i][0]=dp[u][i][1]=val[u];
	for(int i=head[u];i!=-1;i=Edge[i].next)
	{
		int v=Edge[i].en;
		if(vis[v]) continue;
		dfs(v);
		for(int j=K;j>=0;j--)
		{
			for(int k=0;k<=j;k++)
			{
				dp[u][j+2][0]=max(dp[u][j+2][0],dp[u][j-k][0]+dp[v][k][0]);
				dp[u][j+2][1]=max(dp[u][j+2][1],dp[u][j-k][1]+dp[v][k][0]);
				dp[u][j+1][1]=max(dp[u][j+1][1],dp[u][j-k][0]+dp[v][k][1]);
			}
		}
	}
}
int main()
{
	while(scanf("%d%d",&N,&K)!=EOF)
	{
		memset(head,-1,sizeof(head));
		memset(vis,0,sizeof(vis));
		memset(dp,0,sizeof(dp));
		memset(Edge,0,sizeof(Edge));
		num=0;
		int x;
		for(int i=1;i<=N;i++)
		{
			scanf("%d",&val[i]);
		}
		for(int i=1;i<N;i++)
		{
			int st,en;
			scanf("%d%d",&st,&en);
			add(st,en),add(en,st);
		}
		dfs(1);
        printf("%d\n",max(dp[1][K][1],dp[1][K][0]));
	}
	return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值