eclipse无法启动 提示JVM版本太低

转载 2011年01月14日 08:25:00

今天发现eclipse不能打开了 打开出现

version 1.4.2_03 of JVM is not suitable for this product. Version:1.5 or greater is required

 

 

环境变量也设置了 版本是1.6的 在网上查了查

很有可能是oracle自带的那个烂jvm,看看你的环境变量设置:classpath、java_home

1楼的说的没错,都是那个Oracle搞的

遇到过同样的问题
将环境变量path里面有关oracle的全放到最后即可
如:%SystemRoot%/system32;%SystemRoot%;%SystemRoot%/System32/Wbem;C:/Program Files/Microsoft SQL Server/80/Tools/BINN;%JAVA_HOME%/bin;%ANT_HOME%/bin;D:/oracle/ora92/bin;C:/Program Files/Oracle/jre/1.3.1/bin;C:/Program Files/Oracle/jre/1.1.8/bin
本质是要将其放到%JAVA_HOME%/bin;后面

最后把e:/oracle/product/10.1.0/Db_1/jre/1.4.2/bin;放到path的最后 解决了

安装Eclipse时,老提示jvm版本过低,原因和解决办法

今天本来想来安装个Eclipse,可是老提示版本过低,于是看了下环境变量,oracle里面自带了个1.3的版本的jre,但是平时安装myEclipse又没自己安装jdk,解决的办法就是自己再重新配置个...
  • ldk22
  • ldk22
  • 2011年12月21日 22:50
  • 7797

关于更换JDK后启动Eclipse时提示版本过低的一个解决方案

此文主要讲述在不安装jre的情况下使用高版本eclipse的配置步骤.
  • Lsucre
  • Lsucre
  • 2017年08月30日 12:13
  • 938

解决ubuntu上eclipse无法打开,提示jvm版本太旧,至少要jdk1.8以上

1.下载JDK 1.8(linux版); 2.解压到指定目录(我的:/usr/lib/jdk1.8.0_101); 3.配置系统环境变量: $sudo vi /etc/profiled在最后...
  • readnap
  • readnap
  • 2016年08月22日 21:46
  • 1525

关于Eclipse启动报错,jvm版本不匹配的问题

前几天重新下了个eclipse,eclipse需要java环境才能运行起来,我当时电脑上自己装了jdk1.8,然后直接运行新下载的eclipse,说我的jvm版本是1.6,但是我不记得安装过1.6的了...

解决JVM版本低的问题

 系统中已安装jdk1.6。环境变量中,用户变量path设置了D:/java/jdk1.6.0_10/bin;D:/java/jdk1.6.0_10/jre;D:/java/jdk1.6.0_10/l...

oracle带来的JVM版本过低问题

平时都用myeclipse来写java程序,今天下载了个eclipse来用用,解压完eclipse压缩包,启动eclipse时候,遇到了一个错误,eclipse由于版本太低启动不了,在dos命令行输入...

关于解决mac 显示jvm版本过低的问题(设置java home )

原网址:http://www.jianshu.com/p/ea24a96a9e24 安装eclipse提示jvm版本过低,需要安装1.7及以上版本。 于是安装了java 8 和jre1.8 安装...
  • Mappy93
  • Mappy93
  • 2017年09月04日 01:15
  • 268

网页弹框I6版本太低提示下载

  • 2011年11月26日 21:24
  • 13KB
  • 下载

商家QQ在线状态按钮版本太低,不能发起会话,请按如下方法操作

商家QQ在线状态按钮版本太低,不能发起会话,请商家按如下方法操作: 方法一:请登录http://wp.qq.com/ 选择代码类型,点击完全公开,并确认页面上方...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:eclipse无法启动 提示JVM版本太低
举报原因:
原因补充:

(最多只允许输入30个字)