poj 1050最大子矩阵

题目:

To the Max
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 49846 Accepted: 26420

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15


分析:

不需要二维树状数组 因为没有修改操作  只要维护一个前缀和就可以了

具体参:http://blog.pureisle.net/archives/266.html 讲得很好


代码:

#include<iostream>
#include<cstring>
using namespace std;
#define N 110
int a[N][N],f[N];
int main(){
    int n,r;
    cin>>r;
    for(int i=1;i<=r;++i){
        for(int j=1;j<=r;++j){
            cin>>a[i][j];
            a[i][j]+=a[i-1][j];///a[i][j]代表前i行 第j列的部分和
        }
    }
    int ans=a[1][1];
    for(int i=0;i<=r-1;++i){///起始行
        for(int j=i+1;j<=r;++j){///终止行
            ///相当于每次对[i+1,j]行进行操作,将这几行捆绑在一起进行考虑
            ///a[j][k]-a[i][k]即为[i+1,j]行第k列的部分和
            memset(f,0,sizeof(f));
            for(int k=1;k<=r;++k){///转换为一维最大子串和 a[j][k]-a[i][k]相当于一维数组里面每次判断的量
                if(f[k-1]>=0) f[k]=f[k-1]+a[j][k]-a[i][k];
                else f[k]=a[j][k]-a[i][k];
                if(ans<f[k]) ans=f[k];
            }
        }
    }
    cout<<ans<<endl;
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值