poj-2262 Goldbach's Conjecture

题目链接:http://poj.org/problem?id=2262

Goldbach's Conjecture
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28046 Accepted: 10797

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 
Every even number greater than 4 can be 
written as the sum of two odd prime numbers.

For example: 
8 = 3 + 5. Both 3 and 5 are odd prime numbers. 
20 = 3 + 17 = 7 + 13. 
42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 
Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 
Each test case consists of one even integer n with 6 <= n < 1000000. 
Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input

8
20
42
0

Sample Output

8 = 3 + 5
20 = 3 + 17
42 = 5 + 37
题意:好吧,水题又来了。输入一个数n,输出两个数a,b;使得n=a+b,而且a和b都是质数,输出其中a最小的一组。

#include<iostream>
#include<cmath>
using namespace std;
int n,m,p;
bool verify(int n)   //判断函数.判断是否为质数
{
	m=sqrtf(n);
	for(int i=2;i<=m;i++)
	{
		if(n%i==0)
		{return false;break;}
	}
	return true;
}
int main()
{
	while(cin>>n)
	{
		p=0;
		if(n==0) break;
		for(int i=2;i<=n/2;i++)    
		{
			if(verify(i) && verify(n-i))   //使a从2开始,找到一组满足要求的a和b,结束,输出a,b
			{
				p++;
				cout<<n<<" = "<<i<<" + "<<n-i<<endl;
				break;
			}
		}
		if(p==0)
			cout<<"Goldbach's conjecture is wrong."<<endl;   //没有满足要求的a和b
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值