BUPT 网络预选赛邀请赛 B题 B By Recognizing These Guys, We Find Social Networks Useful

题目连接:http://acm.bupt.edu.cn/onlinejudge/newoj/showProblem/show_problem.php?problem_id=197

 

B By Recognizing These Guys, We Find Social Networks Useful
Accept:14    Submit:62
Time Limit:1000MS    Memory Limit:65536KB
Description:

Social Network is popular these days.The Network helps us know about those guys who we are following intensely and makes us keep up our pace with the trend of modern times.
But how?
By what method can we know the infomation we wanna?In some websites,maybe Renren,based on social network,we mostly get the infomation by some relations with those "popular leaders".It seems that they know every lately news and are always online.They are alway publishing breaking news and by our relations with them we are informed of "almost everything".
(Aha,"almost everything",what an impulsive society!)
Now,it's time to know what our problem is.We want to know which are the key relations make us related with other ones in the social network.
Well,what is the so-called key relation?
It means if the relation is cancelled or does not exist anymore,we will permanently lose the relations with some guys in the social network.Apparently,we don't wanna lose relations with those guys.We must know which are these key relations so that we can maintain these relations better.
We will give you a relation description map and you should find the key relations in it.
We all know that the relation bewteen two guys is mutual,because this relation description map doesn't describe the relations in twitter or google+.For example,in the situation of this problem,if I know you,you know me,too.

Input:

The input is a relation description map.
In the first line,an integer t,represents the number of cases(t <= 5).
In the second line,an integer n,represents the number of guys(1 <= n <= 10000) and an integer m,represents the number of relations between those guys(0 <= m <= 100000).
From the second to the (m + 1)the line,in each line,there are two strings A and B(1 <= length[a],length[b] <= 15,assuming that only lowercase letters exist).
We guanrantee that in the relation description map,no one has relations with himself(herself),and there won't be identical relations(namely,if "aaa bbb" has already exists in one line,in the following lines,there won't be any more "aaa bbb" or "bbb aaa").
We won't guarantee that all these guys have relations with each other(no matter directly or indirectly),so of course,maybe there are no key relations in the relation description map.

Output:

In the first line,output an integer n,represents the number of key relations in the relation description map.
From the second line to the (n + 1)th line,output these key relations according to the order and format of the input.

Sample Input:

1
4 4
saerdna aswmtjdsj
aswmtjdsj mabodx
mabodx biribiri
aswmtjdsj biribiri

Sample Output:

1
saerdna aswmtjdsj

 

题意很明显,就是叫我们求双连通分量的关键边

即是说寻找low[x]>dfn[y]的时候

用map标记那条边之后我们就可以按顺序输出了

详见代码:

//求关键边
//双连通分量,概念:一个无向图,如果某一条边被删除,这个图就变成了两个互不干扰的图
//那么这条边就是关键边
//与之类似的还有一个关键点的算法
#pragma warning(disable:4786)
#include<stdio.h>
#include<vector>
#include<iostream>
#include<algorithm>
#include<string>
#include<string.h>
#include<map>
#define maxn 10005

using namespace std;

int n,m,cnt;

map<string,int>my;
map<pair<int,int>,bool>AAA;
char str[maxn][20];
vector<int>g[maxn];
bool used[maxn];
int col[maxn],low[maxn],dfn[maxn];
int Index,ans,sz;
int net[100005][2];

void init()
{
	int i;
	for(i=0;i<=n;i++)
		g[i].clear();
	AAA.clear();
	my.clear();
	memset(used,0,sizeof(used));
	memset(col,0,sizeof(col));
	memset(low,0,sizeof(low));
	memset(dfn,0,sizeof(dfn));
	Index=0,sz=0;
	cnt=0,ans=0;
}

int min(int a,int b)
{
	if(a>b)
		return b;
	else
		return a;
}

void tarjan(int u,int v)
{
	int i;
	bool flag=true;
	col[u]=1;
	Index++;
	dfn[u]=Index;
	low[u]=Index;
	for(i=0;i<g[u].size();i++)
	{
		if(flag&&g[u][i]==v)
		{
			flag=false;
			continue;
		}
		if(col[g[u][i]]==0)
			tarjan(g[u][i],u);
		low[u]=min(low[u],low[g[u][i]]);
		if(low[g[u][i]]>dfn[u])//这里就是满足关键边的条件。
		{
			ans++;
			if(!AAA[make_pair(u,g[u][i])]&&!AAA[make_pair(g[u][i],u)])
			{
				AAA[make_pair(u,g[u][i])]=true;
				AAA[make_pair(g[u][i],u)]=true;
			}
		}
		/*
		if((u==1&&Index>1)||(u!=1&&low[g[u][i]]>=dfn[u]))
			s[u]=1;//被标记了的点就是个点(这一步为验证)
		*/
	}
	col[u]=2;
}

void dfs(int x)
{
	used[x]=1;
	sz++;
	for(int i=0;i<g[x].size();i++)
	{
		int y=g[x][i];
		if(!used[y])
			dfs(y);
	}
}

int main()
{
	int i,t,a,b;
	char s1[20],s2[20];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		init();
		for(i=1;i<=m;i++)
		{
			scanf("%s%s",s1,s2);
			if(my[s1]==0)
			{
				cnt++;
				my[s1]=cnt;
				strcpy(str[cnt],s1);
			}
			if(my[s2]==0)
			{
				cnt++;
				my[s2]=cnt;
				strcpy(str[cnt],s2);
			}
			a=my[s1];
			b=my[s2];
			g[a].push_back(b);
			g[b].push_back(a);
			net[i][0]=a;
			net[i][1]=b;
		}
		dfs(1);
		if(sz!=n)
		{
			puts("0");
			continue;
		}
		tarjan(1,-1);
		printf("%d\n",ans);
		for(i=1;i<=m;i++)
		{
			if(AAA[make_pair(net[i][0],net[i][1])])
				printf("%s %s\n",str[net[i][0]],str[net[i][1]]);
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值