UVa617 - Nonstop Travel

Nonstop Travel 

Fast Phil works the late shift and leaves his company's parking lot at precisely 2:00 AM every morning. His route home is by a straight road which has one or more traffic signals. Phil has always wondered if, given the locations and cycles of each of the traffic signals, are there velocities he can travel home without ever having to speed up or slow down on account of a red light. You are to write a program to satisfy his curiosity.


Your program should find all integer speeds (in miles per hour) which can be used for Phil's trip home. Each speed is a rate (in miles per hour) he can maintain the moment he leaves the parking lot at 2:00 AM until he arrives home (we assume Phil has a long driveway in which to decelerate) such that he never passes through a red signal. He is allowed to pass throgh a signal at the exact moment it turns from yellow to red, or at the exact moment a red signal turns green. Since Phil is a relatively law-abiding citizen, you need only consider speeds less than or equal to 60 mph. Likewise, Phil isn't interested in travelling too slowly, so you should not consider speeds lower than 30 mph.

Input 

Input will consist of one or more sets of data describing a set of traffic signals, followed by the integer -1. The first integer in each set will contain the value N (specifying the number of traffic signals). Nwill be no larger than 6. This value will be followed by N sets of numbers, each containing values (in order) for LGY and RL is a positive real number indicating the location of a traffic signal, in miles, from the parking lot. GY and R are the lengths of time (in seconds) of the green, yellow, and red periods of the corresponding traffic signal's cycle. Phil has learned from an informant in the Highway Department that all N traffic signals start their green period precisely at 2:00 AM.

Output 

Output should consist of the input case number (starting with 1) followed by a list of all valid integer speeds Phil may drive to avoid the red signals. Consecutive integer speeds should be specified in interval notation of the form L-H, where L and H are the lowest and highest speeds for the interval. Intervals of the form L-L (that is, an interval of length 1) shold just be written as L. Intervals should be separated by commas. If there are no valid speeds, you program should display the phrase No acceptable speeds. The Expected Output below illustrates this format.

Sample Input 

1
5.5  40 8 25

3
10.7  10 2 75
12.5  12 5 57
17.93 15 4 67

-1

Sample Output 

Case 1: 30, 32-33, 36-38, 41-45, 48-54, 59-60
Case 2: No acceptable speeds.

余数满足在绿灯和黄灯范围类

#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;

const int N = 8;

struct Traffic
{
    double pos;
    int g, y, r;
};

Traffic traffic[N];
int n;

bool input();
void solve();

int main()
{
#ifndef ONLINE_JUDGE
    freopen("e:\\uva_in.txt", "r", stdin);
#endif

    int t = 1;

    while (input()) {
        printf("Case %d:", t++);
        solve();
    }

    return 0;
}


bool input()
{
    scanf("%d", &n);
    if (n < 0) return false;

    for (int i = 0; i < n; i++) {
        scanf("%lf%d%d%d", &traffic[i].pos, &traffic[i].g, &traffic[i].y, &traffic[i].r);
    }

    return true;
}



void solve()
{
    vector<int> ans;

    for (int i = 30; i <= 60; i++) {
        bool ok = true;
        for (int j = 0; j < n; j++) {
            int t = (int)(traffic[j].pos * 3600 / i);
            if (t % (traffic[j].g + traffic[j].y + traffic[j].r) >= traffic[j].g + traffic[j].y) {
                ok = false;
                break;
            }
        }
        if (ok) ans.push_back(i);
    }

    if (ans.empty()) {
        printf(" No acceptable speeds.\n");
    } else {
        bool first = true;
        for (size_t i = 0; i < ans.size(); i++) {
            size_t j = i;
            while (j + 1 < ans.size() && ans[j + 1] - ans[j] == 1) {
                j++;
            }

            if (first) {
                first = false;
                if (j - i >= 1) {
                    printf(" %d-%d", ans[i], ans[j]);
                } else {
                    printf(" %d", ans[i]);
                }
            } else {
                if (j - i >= 1) {
                    printf(", %d-%d", ans[i], ans[j]);
                } else {
                    printf(", %d", ans[i]);
                }
            }

            i = j;
        }
        printf("\n");
    }
}


 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

kgduu

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值