HDU 1865 1sting

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4151    Accepted Submission(s): 1559


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 


Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 


Output
The output contain n lines, each line output the number of result you can get .
 


Sample Input
  
  
3 1 11 11111
 


Sample Output
  
  
1 2 8
 /*采用递推的思想,求出f(n)=f(n-2)+f(n-1),因为数据量大,采用压位高精度方法,采用普通高精度超时了*/
代码如下

#include<iostream>
#include<cstring>
#include<cstdio>
#define maxn 1000000
using namespace std;
int a[10000][300];/*一个数组单元存放8位数,总共可以存放2400位数*/
char b[maxn];
int main()
{
	int i,j,len,t;
	a[1][0]=1;
	a[2][0]=2;
	for(i=3;i<10000;i++)
	{
		for(j=0;j<300;j++) a[i][j]+=a[i-1][j]+a[i-2][j];
		for(j=0;j<300;j++)
		{
			if(a[i][j]>=100000000) a[i][j+1]+=a[i][j]/100000000,a[i][j]%=100000000;
		}
	}
	cin>>t;
	while(t--)
	{
		cin>>b;
		len=strlen(b);
		int max=299;
		while(!a[len][max]) max--;
		cout<<a[len][max];
		for(int i=max-1;i>=0;i--) printf("%08d",a[len][i]);
		cout<<endl; 
	 } 
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值