Linux下编译Opencv2.3.1遇到的问题

原创 2012年03月23日 12:35:51

我的Linux系统是ubuntu11.10 ,opencv版本是2.3.1

在编译的时候遇到了

1.  cmake -D CMAKE_BUILD_TYPE=RELEASE -D CMAKE_INSTALL_PREFIX=/usr/local opencv-src路径

     make     #遇到下面错误:

make[2]: *** [modules/highgui/CMakeFiles/opencv_highgui.dir/src/cap_ffmpeg.o] Error 1
make[1]: *** [modules/highgui/CMakeFiles/opencv_highgui.dir/all] Error 2
make: *** [all] Error 2
感谢sleegod,他也遇到了同样的问题,这里给出他的博客:
http://blog.csdn.net/sleegod/article/details/6957965

为了方便,这里贴出他的解决方法

解决办法:

通过查看make过程中的错误知道,问题出在OpenCV-2.3.0/modules/highgui/src/cap_ffmpeg_impl.hpp文件中,

参考 https://code.ros.org/trac/opencv/ticket/1020 中 ffmpeg_build.patch 和 ffmpeg_build_2.patch 对 cap_ffmpeg_impl.hpp文件中的出错变量进行替换,

为了方便,附件是改好的cap_ffmpeg_impl.hpp,可直接替换同名原文件,已经测试过成功编译。

重新执行cmake 、 make步骤,此时成功编译不再出错。然后执行sudo make install命令安装。安装过程没有出问题。


2. 在Qt中使用opencv,pro文件中添加: 

INCLUDEPATH += /usr/local/include
LIBS += /usr/local/lib/libopencv_core.so.2.3.0 /usr/local/lib/libopencv_highgui.so.2.3.0  #lib文件没列全

并在正确mian.cpp文件中正确包含头文件后build, 出现以下错误:

error: undefined reference to av_guess_codec@...............

/usr/include/opencv/cxmisc.h:516: error: ‘CV_DEPTH_MAX’ was not declared in this scope

还有很多类似的编译链接错误,省略

解决办法: 

sudo apt-get install build-essential libgtk2.0-dev libavcodec-dev libavformat-dev libjpeg62-dev libtiff4-dev cmake libswscale-dev libjasper-dev

以上缺少什么安装什么,安装完后rebuild 运行,OK!

参考:http://www.matrixq.net/2011/10/10320.html?utm_source=rss


[附件] http://download.csdn.net/detail/sleegod/3780732


版权声明:本文为博主原创文章,未经博主允许不得转载。

centos7.0安装opencv出现问题

问题描述: [ 17%] Building CXX object modules/highgui/CMakeFiles/opencv_highgui.dir/src/grfmt_jpeg2000.c...
  • lwgkzl
  • lwgkzl
  • 2017年08月08日 22:43
  • 328

配置openCV出错

OpenCV Error: Assertion failed (size.width>0 && size.height>0) in cv::imshow, file C:\builds\master_...

opencv常见编译错误

OpenCV的全称是:Open Source Computer Vision Library,于1999年由Intel建立,现在由Willow Garage提供支持。OpenCV是一个基于BSD许可证...

caffe安装吐血总结 opencv的问题,ubuntu版本问题

转自:http://blog.csdn.net/caozhantao/article/details/51479172 这周安装了caffe的windows版本和Linux版本,依赖关系太多,如...

Ubuntu 14.04下成功安装ffmpeg与编译配置opencv-2.4.10

最近在Linux下配置交叉编辑环境,安装Qt、ffmpeg,编译安装OpenCV各种版本,各种郁闷,终于都搞定了,趁着热乎着,赶紧吐槽一下!     好了,言归正传。 1. 关于交叉编译环境的配置...

xubuntu编译OpencV2.4.2出现make交叉编译出现错误。

假定已经有安装包。 更新软件列表,升级 sudo apt-get update sudo apt-get upgrade 安装依赖包 sudo apt-get install build-essent...

OpenCV2.3.1在Ubuntu11.10上编译错误解决方法

经过上次介绍Ubuntu 全新编译安装 OpenCV 2.3之后,很快,新的2.3.1又出来了,经不住诱惑,马上试试 但是,不知道大家在编译最新的2.3.1的时候出现错误没,反正我出现错误了,具...
  • xizhibei
  • xizhibei
  • 2011年11月26日 21:53
  • 10843

opencv安装过程中的问题与解决

/usr/include/string.h:369:28: error: previous declaration of ‘const char* strcasestr(const char*, co...

Linux下编译Opencv2.3.1遇到的问题

原文地址:http://blog.csdn.net/xizero00/article/details/7386695# 我的Linux系统是ubuntu11.10 ,opencv版本是2.3.1...

ubuntu(linux)下安装openCV(ffmpeg导致的编译不通过的解决办法)

关于这个问题,晚上有很多现成的方法,但是很多方法也都存在问题,所以自己总结一下,把自己的安装过程记录下来,也方便以后查阅。 1.需要的包:     GCC 4.4.x 或更高     CMake ...
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:Linux下编译Opencv2.3.1遇到的问题
举报原因:
原因补充:

(最多只允许输入30个字)