hdu1524(尼姆博弈)

A Chess Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1207    Accepted Submission(s): 553


Problem Description
Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!
 

Input
Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
 

Output
There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.
 

Sample Input
  
  
4 2 1 2 0 1 3 0 1 0 2 0 2 0 4 1 1 1 2 0 0 2 0 1 2 1 1 3 0 1 3 0
 

Sample Output
  
  
WIN WIN WIN LOSE WIN
 

Source
 

Recommend

LL   |   We have carefully selected several similar problems for you:  1404 1730 1729 1079 1760 

 

      本题给定有向无环图,然后在某些位置放置一些棋子,谁先无路可走就输;问先走者是否有必胜的把握。这是个常见的尼姆博弈模型。图中某点的SG值就是后继节点关于自然数集的补集的最小值,即SG函数中的mem操作。转换为分析PN局了。

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

vector<int>g[1000+10];
const int MAXN=1010; 
int SG[MAXN];

int GetSG(int id)
{
	if(-1!=SG[id])
		return SG[id];
	bool visited[MAXN];
	memset(visited,false,sizeof(visited));
	for(int i=0;i<g[id].size();i++)
	{
		visited[GetSG(g[id][i])]=true;
	}
	for(i=0;;i++)
		if(!visited[i])
			break;
		return SG[id]=i;
}

int main()
{
	int n,m,i,tmp,q,st;
	while(cin>>n)
	{
		for(i=0;i<n;i++)
			g[i].clear();
		
		for(i=0;i<n;i++)
		{
			cin>>m;
			while(m--)
			{
				cin>>tmp;
				g[i].push_back(tmp);
			}
		}
		memset(SG,-1,sizeof(SG));
		while(cin>>q)
		{
			if(!q)break;
			int sum=0;
			while(q--)
			{
				cin>>st;
				sum^=GetSG(st);
			}
			if(sum==0)
				cout<<"LOSE"<<endl;
			else cout<<"WIN"<<endl;
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值