HDU 1789 Doing Homework again(贪心)

原题链接

Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

题目大意

现有n项任务,每天可以完成其中的一项,输入的第一行给出每一项任务的截止日,第二行给出如果这项任务不能在截止日前完成会受到的惩罚。要找出一种使惩罚最少的方案,输出受到的最小惩罚。

解题思路

用贪心的思想,首先对每一项任务,根据惩罚从从大到小排序,惩罚相同的截止日小的靠前排,这样我们就有了一个任务序列。在这个序列里从前往后依次安排任务,从每项任务的截止日开始往前找空位即可,如发现无法找到,就在最终结果中加上这项任务的惩罚。

AC代码

#include<bits/stdc++.h>
#define ll long long
#define rep(i,a,b) for (int i=(a),_ed=(b);i<=_ed;i++)
#define fil(a,b) memset((a),(b),sizeof(a))
#define cl(a) fil(a,0)
#define PI 3.1415927
#define inf 0x3f3f3f3f
using namespace std;
struct node
{
    int a;
    int b;
};
bool cmp(node &x,node &y)
{
    if(x.b==y.b) return x.a<y.a;
    else return x.b>y.b;
}
int main()
{
    int t,n;
    node ve[1005];
    int vis[1005];
    cin>>t;
    while(t--)
    {
         int res=0;
         cl(vis);
         int flag=0;
         cin>>n;
         rep(i,1,n)
         {
            scanf("%d",&ve[i].a);
         }
         rep(i,1,n)
         {
            scanf("%d",&ve[i].b);
         }
         sort(ve+1,ve+1+n,cmp);
         rep(i,1,n)
         {
            flag=0;
            for(int j=ve[i].a;j>=1;j--)
            {
                if(!vis[j])
                {
                    vis[j]=1;
                    flag=1;
                    break;
                }
            }
            if(!flag) res+=ve[i].b;
         }
         cout<<res<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值