hdu 5210 Delete(set)

Delete

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 209    Accepted Submission(s): 142


Problem Description
WLD likes playing with numbers. One day he is playing with N integers. He wants to delete K integers from them. He likes diversity, so he wants to keep the kinds of different integers as many as possible after the deletion. But he is busy pushing, can you help him?
 

Input
There are Multiple Cases. (At MOST 100 )

For each case:

The first line contains one integer N(0<N100) .

The second line contains N integers a1,a2,...,aN(1aiN) , denoting the integers WLD plays with.

The third line contains one integer K(0K<N) .
 

Output
For each case:

Print one integer. It denotes the maximum of different numbers remain after the deletion.
 

Sample Input
  
  
4 1 3 1 2 1
 

Sample Output
  
  
3
Hint
if WLD deletes a 3, the numbers remain is [1,1,2],he'll get 2 different numbers. if WLD deletes a 2, the numbers remain is [1,1,3],he'll get 2 different numbers. if WLD deletes a 1, the numbers remain is [1,2,3],he'll get 3 different numbers.
题意:
从n个数中删k个数,求剩下的数中最多有多少个不同的数
代码:
#include<cstdio>
#include<set>
using namespace std;

int a[105];

int main()
{
    set<int> st;
    int n;
    while(scanf("%d",&n)==1)
    {
        st.clear();
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            st.insert(a[i]);
        }
        int cnt=n-st.size();
        int k;
        scanf("%d",&k);
        if(k<=cnt)
            printf("%d\n",st.size());
        else
            printf("%d\n",st.size()-k+cnt);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值