06-图7. How Long Does It Take (25)

Given the relations of all the activities of a project, you are supposed to find the earliest completion time of the project.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (<=100), the number of activity check points (hence it is assumed that the check points are numbered from 0 to N-1), and M, the number of activities. Then M lines follow, each gives the description of an activity. For the i-th activity, three non-negative numbers are given: S[i], E[i], and L[i], where S[i] is the index of the starting check point, E[i] of the ending check point, and L[i] the lasting time of the activity. The numbers in a line are separated by a space.

Output Specification:

For each test case, if the scheduling is possible, print in a line its earliest completion time; or simply output "Impossible".

Sample Input 1:
9 12
0 1 6
0 2 4
0 3 5
1 4 1
2 4 1
3 5 2
5 4 0
4 6 9
4 7 7
5 7 4
6 8 2
7 8 4
Sample Output 1:
18
Sample Input 2:
4 5
0 1 1
0 2 2
2 1 3
1 3 4
3 2 5
Sample Output 2:
Impossible

提交代

————————————————

这个题目有几个坑,被我趟了。。。。

知识点如下。

1,对于图中有环的判定。主要用到的是队列,入度和出度的概念。在云课堂上的拓扑排序中有讲解。

2,对于终点会有多个的情况下,需要找到最大值。遍历所有的出度为0的点。

3,


代码如下

#include <iostream>
#include <queue>

using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

#define MAX 110
#define INF 10000
#define max(a,b) (a)>(b)?(a):(b)


int N=0,M=0;
int cost[MAX][MAX];
int Earlist[MAX],indegree[MAX],outdegree[MAX];

void Creat()
{
	cin>>N>>M;
	for(int i=0; i<N; i++)
	{
		for(int j=0; j<N; j++)
		{
			cost[i][j]=-1;
		}
		Earlist[i]=0;
		indegree[i]=0;
		outdegree[i]=0;
	}
	for(int i=0; i<M; i++)
	{
		int v1,v2,c;
		cin>>v1>>v2>>c;
		cost[v1][v2]=c;//v1<v2!!
		outdegree[v1]++;
		indegree[v2]++;
	}
}

int Ear()
{
	queue<int> q;
	int i=0,front=0;
	for(i=0; i<N; i++)
	{
		if(indegree[i]==0)
		{
			q.push(i);
			indegree[i]--;
		}
	}
	int cnt=0;
	while(!q.empty())
	{
		front=q.front();q.pop();
		cnt++;
		for(i=0; i<N; i++)
		{
			if(cost[front][i] >=0)
			{
				indegree[i]--;
				Earlist[i]=max(Earlist[i],Earlist[front]+cost[front][i]);
			}
		}
		for(i=0; i<N; i++)
		{
			if(indegree[i] == 0)
			{
				q.push(i);
				indegree[i]--;
			}
		}
	}
	if(cnt==N)
	{
		return Earlist[front];
	}
	return -1;
	
}

int main(int argc, char** argv) {
	int res=0;
	Creat();
	if(Ear()==-1)
	{
		cout<<"Impossible"<<endl;
	}
	else
	{
		for(int i=0; i<N; i++)
		{
			if(outdegree[i] == 0)
			{
				res=max(res,Earlist[i]);
			}
		}
		cout<<res<<endl;
	}
	
	return 0;
}








  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
checking whether the compiler supports GNU C++... yes checking whether g++ accepts -g... yes checking for g++ option to enable C++11 features... none needed checking dependency style of g++... gcc3 checking how to run the C preprocessor... gcc -std=gnu11 -E checking for x86_64-w64-mingw32-ranlib... no checking for ranlib... ranlib checking for x86_64-w64-mingw32-dlltool... no checking for dlltool... no checking for x86_64-w64-mingw32-ar... no checking for x86_64-w64-mingw32-lib... no checking for x86_64-w64-mingw32-link... no checking for ar... ar checking the archiver (ar) interface... ar checking dependency style of gcc -std=gnu11... gcc3 checking for x86_64-w64-mingw32-as... no checking for as... as checking whether dlltool supports --temp-prefix... yes checking whether to build a w32api package for Cygwin... no checking whether to build the Win32 libraries... yes checking whether to build the Win64 libraries... yes checking whether to build the WinARM32 libraries... no checking whether to build the WinARM64 libraries... no checking whether to use genlib... no checking whether to enable globbing... no checking whether to enable private exports... no checking whether to enable delay import libs... no checking what to provide as libmsvcrt.a... msvcrt-os checking whether to include support for Control Flow Guard... no checking whether to enable experimental features... no checking whether the compiler supports -municode... no checking for stdio.h... yes checking for stdlib.h... yes checking for string.h... yes checking for inttypes.h... yes checking for stdint.h... yes checking for strings.h... yes checking for sys/stat.h... yes checking for sys/types.h... yes checking for unistd.h... yes checking for _mingw_mac.h... no
最新发布
06-10

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值