1007. Maximum Subsequence Sum (25)

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

提交代

——————————

这个就是最大子列和问题,已经做过一遍了,在这里。

http://blog.csdn.net/xkzju2010/article/details/45968377

然后,再做的话,还是有点小问题,没能一下子做好。

问题是res的赋初值上面,应该赋值为-1,而不是0.

#include <iostream>

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main(int argc, char** argv) {
	int K,a[10010];
	bool flag=false;
	scanf("%d",&K);
	for(int i=0; i<K; i++)
	{
		scanf("%d",&a[i]);
		if(a[i]>=0) flag=true;
	}
	int max=0;
	int res=-1,begin=0,end=0,begin1=0;
	for(int i=0; i<K; i++)
	{
		max+=a[i];
		if(max>res)
		{
			res=max;
			end=i;
			begin=begin1;
		}
		else if(max<0)
		{
			max=0;
			begin1=i+1;
		}
	}
	if(!flag)
		printf("0 %d %d\n",a[0],a[K-1]);
	else
		printf("%d %d %d\n",res,a[begin],a[end]);
	
	
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值