【Uva 1583】 Digit Generator

Description

For a positive integer N , the digit-sum of N is defined as the sum of N itself and its digits. When M is the digitsum of N , we call N a generator of M .

For example, the digit-sum of 245 is 256 (= 245 + 2 + 4 + 5). Therefore, 245 is a generator of 256.

Not surprisingly, some numbers do not have any generators and some numbers have more than one generator. For example, the generators of 216 are 198 and 207.

You are to write a program to find the smallest generator of the given integer.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case takes one line containing an integer N , 1   N   100, 000 .

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain a generator of N for each test case. If N has multiple generators, print the smallest. If N does not have any generators, print 0.

The following shows sample input and output for three test cases.

Sample Input

3
216
121
2005

Sample Output

198
0
1979

解题思路

求出最小的x,使 x + x的各位数字之和 为 y.
直接枚举就行了.

参考代码

#include <stdio.h>
const int MAX = 100005;
int ans[MAX]={0};
int main()
{
    int T,n,i;
    for (i = 1;i < MAX;i++){
        int x = i,y = i;
        while (x > 0){
            y += x%10; //从x最后一位开始加到y中
            x /= 10;
        }
        if (!ans[y])//紫书中的条件为 (ans[y] == 0 || m < ans[y]),其实后面一个没有必要,因为循环是从小到大,因此ans[y]存起来的一定是最小的那个
            ans[y] = i;
    }
    scanf("%d",&T);
    while (T--){
        scanf("%d",&n);
        printf("%d\n",ans[n]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值