关闭

使用unordered_map编译报#error This file requires compiler and library support......

5386人阅读 评论(4) 收藏 举报
分类:

今天把几个map替换成unordered_map后编译出现了如下错误信息:

#error This file requires compiler and library support for the upcoming ISO C++ standard, C++0x. This support is currently experimental, and must be enabled with the -std=c++0x or -std=gnu++0x compiler options.


提示上加上-std=c++0x或者-std=gnu++0x选项。加上就解决了~

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:329797次
    • 积分:3538
    • 等级:
    • 排名:第9301名
    • 原创:74篇
    • 转载:37篇
    • 译文:0篇
    • 评论:76条
    好站链接
    尤龙同学的代码与诗歌