HDU 1242:Rescue(BFS+优先队列)

Rescue

Time limit:1000 ms Memory limit:32768 kB OS:Windows


Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel’s friends want to save Angel. Their task is: approach Angel. We assume that “approach Angel” is to get to the position where Angel stays. When there’s a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. “.” stands for road, “a” stands for Angel, and “r” stands for each of Angel’s friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing “Poor ANGEL has to stay in the prison all his life.”

Sample Input

7 8
#.#####.
#.a#..r.
#..#x…
..#..#.#
#…##..
.#……
……..

Sample Output

13


题意:

拯救Angel~, r 代表Angel的朋友,#代表墙壁,x代表卫兵,.代表路,r可以走上下左右四个方向,走路需要1时间,打败卫兵需要额外1时间,问他最快救到Angel的时间。如果救不到就输出Poor ANGEL has to stay in the prison all his life.

解题思路:

用优先队列和BFS,步数小的优先级的最高。


Code:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;

const int maxn=100+5;
int vis[maxn][maxn];
char mp[maxn][maxn];
int n,m;
int dx[]= {-1,-1,0,1,1,1,0,-1};
int dy[]= {0,1,1,1,0,-1,-1,-1};

struct Node
{
    int x,y;
};
queue<Node> Q;

bool check(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m)
        return false;
    if(vis[x][y])
        return false;
    if(mp[x][y]!='@')
        return false;
    return true;
}

void BFS(int x1,int y1)
{
    while(!Q.empty())
        Q.pop();

    vis[x1][y1]=1;
    Q.push((Node)
    {
        x1,y1
    });
    while(!Q.empty())
    {
        Node &u=Q.front();
        Q.pop();
        for(int i=0; i<8; i++)
        {
            int x=u.x+dx[i];
            int y=u.y+dy[i];
            if(check(x,y))
            {
                vis[x][y]=1;
                Q.push(Node{x,y});
            }
        }
    }
}

int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0)
            break;
        for(int i=0; i<n; i++)
            scanf("%s",mp[i]);

        int cnt=0;
        mem(vis,0);
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                if(mp[i][j]=='@'&&vis[i][j]==0)
                {
                    cnt++;
                    BFS(i,j);
                }
        printf("%d\n",cnt);

    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值