Why Did the Cow Cross the Road II - UPCOJ 3438 - 动态规划DP

140 篇文章 0 订阅
48 篇文章 1 订阅

题目:

题目描述
Farmer John raises N breeds of cows (1≤N≤1000), conveniently numbered 1…N. Some pairs of breeds are friendlier than others, a property that turns out to be easily characterized in terms of breed ID: breeds a and b are friendly if |a−b|≤4, and unfriendly otherwise.
A long road runs through FJ’s farm. There is a sequence of N fields on one side of the road (one designated for each breed), and a sequence of N fields on the other side of the road (also one for each breed). To help his cows cross the road safely, FJ wants to draw crosswalks over the road. Each crosswalk should connect a field on one side of the road to a field on the other side where the two fields have friendly breed IDs (it is fine for the cows to wander into fields for other breeds, as long as they are friendly). Each field can be accessible via at most one crosswalk (so crosswalks don’t meet at their endpoints).

Given the ordering of N fields on both sides of the road through FJ’s farm, please help FJ determine the maximum number of crosswalks he can draw over his road, such that no two intersect.

输入
The first line of input contains N. The next N lines describe the order, by breed ID, of fields on one side of the road; each breed ID is an integer in the range 1…N. The last N lines describe the order, by breed ID, of the fields on the other side of the road. Each breed ID appears exactly once in each ordering.

输出
Please output the maximum number of disjoint “friendly crosswalks” Farmer John can draw across the road.

样例输入

6
1 2 3 4 5 6
6 5 4 3 2 1

样例输出

5

题意:

  给你一个n,然后是2*n个点,对应a[n]b[n]两个数组,如果abs(a[i]-b[j])<=4,那么就可以将这两个点连起来。问,在连线不交叉的情况下,最多可以连多少根线。


思路:

  脑补了一下连线不能交叉的样子,像是代码归并对比的那样,于是想到了最长公共子序列。


实现:

#include <bits/stdc++.h>
using namespace std;
int n,x[1007],y[1007],dp[1007][1007];
int main() {
    ios_base::sync_with_stdio(false);cin.tie(nullptr);
    while(memset(dp,0,sizeof dp), cin >> n) {
        for(int i=1 ; i<=n ; i++) cin >> x[i];
        for(int i=1 ; i<=n ; i++) cin >> y[i];
        for(int i=1 ; i<=n ; i++) {
            for(int j=1 ; j<=n ; j++) {
                if(abs(x[i]-y[j]) <= 4) dp[i][j] = dp[i-1][j-1]+1;
                else dp[i][j] = max(dp[i][j-1],dp[i-1][j]);
            }
        }
        cout << dp[n][n] << '\n';
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值