ZOJ 3551 Bloodsucker

23 篇文章 0 订阅

这是今天比赛中的一道题目,比赛的时候没弄懂怎么做,那时候对期望忘没了啊、、后来比赛结束之后才知道只是一道概率DP的题目、、可是不太会啊,所以就问同学+看题解终于弄懂了啊、、不容易啊、、

题意:一共有n个人,每天都会有一个人又一定的几率变成吸血鬼,求所有人变成吸血鬼的期望。

思路:概率DP,我们可以逆推,dp[i]代表i个人到所有人变成吸血鬼的概率,往上逆推。

这里我说一下状态方程的推导:

人与僵尸相遇的概率Pa为n*(n-i)/(n*(n-1)/2)。 n*(n-i)这是僵尸与人所有组合的情况,n*(n-1)/2 其实是C(n,2);表示的是所有人和僵尸出现任意两个的所有情况。

我们知道当前的状态可以由之前的状态转变而来,就比如说这道题。僵尸与人相遇后会有两种状态:变,或者不变。所以就逆推僵尸的个数,也就是人变成僵尸。

所以可以得到:dp[i] = (dp[i+1]+1)*p1(变) + (dp[i]+1)*p2(不变)。其中p1+p2 = 1;所以通过简单地化简就可以得到:

dp[i] = (dp[i+1]+1)/p1;

ps:这里的p1,并不是变成僵尸的概率P,而是僵尸与人相遇的概率Pa与P的乘积。所以P1 = P*Pa;

Bloodsucker

Time Limit: 2 Seconds      Memory Limit: 65536 KB

In 0th day, there are n-1 people and 1 bloodsucker. Every day, two and only two of them meet. Nothing will happen if they are of the same species, that is, a people meets a people or a bloodsucker meets a bloodsucker. Otherwise, people may be transformed into bloodsucker with probability p. Sooner or later(D days), all people will be turned into bloodsucker. Calculate the mathematical expectation of D.

Input

The number of test cases (T, T ≤ 100) is given in the first line of the input. Each case consists of an integer n and a float number p (1 ≤ n < 100000, 0 < p ≤ 1, accurate to 3 digits after decimal point), separated by spaces.

Output

For each case, you should output the expectation(3 digits after the decimal point) in a single line.

Sample Input
1
2 1

Sample Output
1.000
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int main()
{
    double dp[101000];
    int i, n, t;
    double p;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %lf",&n, &p);
        dp[n] = 0;
        for(i = n-1; i >= 1; i--)
        {
            double s1, s2, p1;
            s1 = (double)n*(n-1)/2;//这里必须用强制转换,转换成double类型的,*1.0却不行,不知道怎么了啊、、
            s2 = (double)i*(n-i);
            p1 = p*s2/s1;
            dp[i] = 1.0*(dp[i+1]*p1+1)/p1;
        }
        printf("%.3f\n",dp[1]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值