关闭

mac 安装robotFramwork环境 以及wxPython 无法安装问题解决

标签: wxpythonrobotFramwork安装
3338人阅读 评论(6) 收藏 举报
分类:

mac上装robotFramwork 的坑有很多,找了很久,终于完美解决了wxPython不兼容问题等

步骤

1. mac自带python环境,检查python环境,命令行

python --version

显示

Python 2.7.10


2.安装robotFramwork

sudo easy_install robotframework

3.安装robotFramwork-ride

sudo easy_install robotframework-ride

4.命令行运行

 ride.py

会提示

wxPython not found.

You need to install wxPython 2.8.12.1 or 3.0.2 or newer with unicode support to run RIDE. wxPython can be downloaded from http://sourceforge.net/projects/wxpython/files/wxPython/

5.安装wxPython

 根据提示去 https://sourceforge.net/projects/wxpython/files/wxPython/    下载



然后打开下载的dmg


直接点击打开,这种安装方式,亲测是完全无效的

所以正确的安装方式应该是这样的  点击安装包右键选择显示内容,会看到右边的文件夹


打开Contents/Resources/  


将usr中的 local/lib 拷贝到usr/local 目录下 即下方图片中的usr



然后运行之前拷贝到桌面上的 postflight

切换到post flight所在的目录,运行命令

sudo ./postflight

6.执行ride.py会出现以下提示

python should be executed in 32-bit mode with wxPython on OSX.

这是因为prthon驱动是32位的,而我们安装的是64位的

输入以下命令强制执行32位

defaults write com.apple.versioner.python Prefer-32-Bit -bool yes

然后运行ride.py 就成功了




在此感谢知乎上某位大神回答的提供的思路

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:61120次
    • 积分:873
    • 等级:
    • 排名:千里之外
    • 原创:38篇
    • 转载:4篇
    • 译文:1篇
    • 评论:6条
    最新评论