关闭

Backbone 1.0.0 版 API 解析

标签: backbone
458人阅读 评论(0) 收藏 举报
分类:

Backbone官网: http://backbonejs.org

Github地址:https://github.com/jashkenas/backbone/

 

Backbone's only hard dependency is Underscore.js ( >= 1.5.0). For RESTful persistence, history support via Backbone.Router and DOM manipulation with Backbone.View, include json2.js, and either jQuery ( >= 1.7.0) or Zepto.

即:Backbone严重依赖于underscore.js,且underscore.js的版本不能低于1.5.0。

对于其他的特性,eg:history Router Dom View等依赖于json2.js 和 jquery或者Zepto,如果使用jquery,要使用的版本不能低于1.7.0.

 

1.0 版本的Backbone比其他版本,有一些改动,尤其是:

Model validation is now only enforced by default in save — not in set unless the{validate:true} option is passed. Model validation now fires an "invalid" event instead of "error".

Model使用set方法时并不一定会进行validate了,只有在save中会强制执行validate。如果想在set中进行校验,可以在set中传入第二个参数:{validate:true}

0
0

查看评论
* 以上用户言论只代表其个人观点,不代表CSDN网站的观点或立场
    个人资料
    • 访问:7268次
    • 积分:141
    • 等级:
    • 排名:千里之外
    • 原创:6篇
    • 转载:8篇
    • 译文:0篇
    • 评论:2条
    文章存档