一客户在Cisco3640上配置VoIP

转载 2007年10月13日 22:29:00
下面是一个Cisco 3640的VOIP配置,对方的结构是北京和汕头两地做VoIP,后接阿尔卡特的PBX。 

这里面有很多值得注意的地方,与大家一起分享快乐! 

北京一方的3640配置: 
Beijing#sh run 
Building configuration... 

Current configuration: 
! 
version 12.0 
service timestamps debug uptime(设定Debug跟踪日志显示其时间) 
service timestamps log uptime(设定看Log时显示其时间) 
no service password-encryption(口令不加密) 
! 
hostname Beijing(主机名) 
! 
enable secret 5 $1$R.66$z.BUjhNsJcIr8KCcS9uxG. 
! 
! 
! 
! 
! 
voice-card 1(定义语音卡1) 
! 
voice-card 3(定义语音卡3) 
! 
ip subnet-zero 
no ip domain-lookup 
! 
isdn voice-call-failure 0 
! 
! 
! 
! 
controller E1 1/0(配置 E1语音卡) 
framing NO-CRC4 
ds0-group 0 timeslots 1-15,17-31 type e&m-wink-start(定义语音卡的类型为E&M卡) 
cas-custom 0 
! 
controller E1 3/0(配置 E1语音卡) 
framing NO-CRC4 
ds0-group 0 timeslots 1-15,17-31 type e&m-wink-start(定义语音卡的类型为E&M卡) 
cas-custom 0 
! 
! 
! 
interface BRI0/0 
no ip address 
no ip directed-broadcast 
shutdown 
isdn guard-timer 0 on-expiry accept 
! 
interface FastEthernet0/0 
no ip address 
no ip directed-broadcast 
shutdown 
duplex auto 
speed auto 
! 
interface Serial0/0 
description "Link to MainLand_Shantou by NCIC lease line" 
ip address 192.168.1.1 255.255.255.252 
no ip directed-broadcast 
no ip mroute-cache 
no fair-queue 
! 
interface Serial0/1 
no ip address 
no ip directed-broadcast 
shutdown 
clockrate 2000000 
! 
ip classless 
no ip http server 
! 
! 
voice-port 1/0:0(配置模拟语音端口) 
compand-type a-law 
! 
voice-port 3/0:0(配置模拟语音端口) 
compand-type a-law 
! 
dial-peer voice 1 voip (定义拨号对等体到语音) 
destination-pattern +445...(为拨号对等体分配电话号码,其中.为通配符) 
session target ipv4:192.168.1.2(定义Voip路由,为对端的IP地址) 
req-qos guaranteed-delay (语音数据流RVSP的保证,其中Guaranteed-dealy可用于保证整个
网络的延时) 
ip precedence 5(IP优先级,5为关键) 
! 
dial-peer voice 2 pots(定义拨号对等体到语音物理端口) 
destination-pattern +3...(定义电话话码以3开头的) 
port 1/0:0(定义语音端口) 
! 
dial-peer voice 3 pots(定义拨号对等体到语音物理端口) 
destination-pattern +3...(定义电话话码以3开头的) 
port 3/0:0(定义语音端口) 
! 
! 
line con 0(设定登陆) 
transport input none 
line aux 0 
line vty 0 4(允许用Telnet) 
password cisco(口令为Cisco) 
login 
! 
end 

Beijing# 


汕头一方的3640配置 
Shantou#sh run 
Building configuration... 

Current configuration: 
! 
version 12.0 
service timestamps debug uptime 
service timestamps log uptime 
no service password-encryption 
! 
hostname Shantou 
! 
enable secret 5 $1$dB/c$tnrMU9IxFCJdix5ssHAdH/ 
! 
! 
! 
! 
! 
voice-card 1 
! 
voice-card 2 
! 
ip subnet-zero 
no ip domain-lookup 
! 
isdn voice-call-failure 0 
! 
! 
! 
! 
controller E1 1/0 
framing NO-CRC4 
ds0-group 0 timeslots 1-15,17-31 type e&m-immediate-start 
cas-custom 0 
! 
controller E1 2/0 
framing N 
ds0-group 0 timeslots 1-15,17-31 type e&m-immediate-start 
cas-custom 0 
! 
! 
! 
interface BRI0/0 
no ip address 
no ip directed-broadcast 
encapsulation ppp 
isdn guard-timer 0 on-expiry accept 
ppp multilink 
! 
interface FastEthernet0/0 
no ip address 
no ip directed-broadcast 
shutdown 
duplex auto 
speed auto 
! 
interface Serial0/0 
no ip address 
no ip directed-broadcast 
no ip mroute-cache 
shutdown 
no fair-queue 
clockrate 2000000 
! 
interface Serial0/1 
ip address 192.168.1.2 255.255.255.252 
no ip directed-broadcast 
! 
ip classless 
! 
no ip http server 
! 
! 
voice-port 1/0:0 
compand-type a-law 
! 
voice-port 2/0:0 
compand-type a-law 
! 
dial-peer voice 20 voip 
destination-pattern +3... 
session target ipv4:192.168.1.1 
req-qos guaranteed-delay 
ip precedence 5 
! 
dial-peer voice 10 pots 
destination-pattern +448... 
port 1/0:0 
! 
dial-peer voice 30 voip 
destination-pattern +4... 
session target ipv4:192.168.1.1 
req-qos guaranteed-delay 
ip precedence 5 
! 
dial-peer voice 40 pots 
destination-pattern +449... 
port 2/0:0 
! 
! 
line con 0 
transport input none 
line aux 0 
line vty 0 4 
password cisco 
login 
! 
end 

Shantou# 
 

iOS应用中通过设置VOIP模式实现休眠状态下socket的长连接

如果你的应用程序需要在设备休眠的时候还能够收到服务器端发送的消息,那我们就可以借助VOIP的模式来实现这一需求。但是如果的应用程序并不是正真的VOIP应用,那当你把你的应用提交到AppStore的时候...
  • missautumn
  • missautumn
  • 2013年12月03日 21:53
  • 11898

IOS实现Voip应用后台运行需要的几个配置项

voip类的app允许用户使用Internet网络而不是手机的蜂窝网络打电话,因此这一类的app需要保持同它相关的服务的网络连接,用以厚道来电消息和其他数据。IOS系统不是通过一直让app处于激活状态...
  • ji5ji
  • ji5ji
  • 2016年06月17日 22:44
  • 2730

使用miniSipServer为中小企业搭建VOIP服务器

使用miniSipServer为中小企业搭建IP-PBX系统如何知道的miniSipServer最开始打算使用的是3CX phone system,也是一种PBX系统,根据网上的一个帖子《3CX vo...
  • xxxholiclamp
  • xxxholiclamp
  • 2015年04月28日 14:59
  • 2835

基于Linux开源VOIP系统LinPhone[三]

在LinPhone这个系统中,第二个我们要介绍的第三方库组件:speex,Speex是一套主要针对语音的开源免费,无专利保护的音频压缩格式。Speex工程着力于通过提供一个可以替代高性能语音编解码来降...
  • wavemcu
  • wavemcu
  • 2013年02月05日 14:18
  • 5220

VOIP开源项目源码地址

VoIP bookmarks from Klaus Darilion Below you will find descriptions and links to SIP and RTP stac...
  • htt9931
  • htt9931
  • 2015年04月14日 16:38
  • 1504

openwrt上的asterisk的VOIP系统的建立

原文地址:openwrt上的asterisk的VOIP系统的建立作者:cliff 网络电话很便宜。自己搭一个网络电话系统更好玩。 这里写的是两年前我的网络电话系统。现在个人使用的系统简单得多了。 ...
  • killmice
  • killmice
  • 2015年09月06日 18:55
  • 2361

怎样打开VOIP与SIP

什么是VOIP?     VoIP的完整名字是Voice over Internet Protocol,翻译过来就是因特网语音,可以简单理解为一种用因特网系统代替传统电话通讯系统进行语音通话的技术。...
  • wds1181977
  • wds1181977
  • 2013年12月24日 18:18
  • 2283

自己动手搭建免费VoIP服务器

通过使用开源软件Asterisk,自己动手搭建免费VoIP服务器。 服务器别闲着,博主又要给大家带来新的玩法咯 1. 这里以 Debian 为例子,安装 Asterisk apt-get upda...
  • yuesichiu
  • yuesichiu
  • 2014年12月03日 10:28
  • 13416

Freepbx-VPS搭建SIP服务器实现VOIP通话[图文教程]

简介 Freepbx是一个集成了Asterisk的工具,提供GUI (graphical user interface)用户图形界面。通过Freepbx可以十分方便的配置各类电话系统。由于Aster...
  • brandon2015
  • brandon2015
  • 2016年07月02日 17:54
  • 6200

基于Android的VoIP系统实现原理

VoIP(Voice over Internet Protocol)即首先数字化语音信号并压缩成帧,转换为IP数据包在网络上传输,以此完成语音通话的业务,是一种利用IP协议传输语音数据的、新兴的通信技...
  • cc20032706
  • cc20032706
  • 2014年05月14日 13:20
  • 1404
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章:一客户在Cisco3640上配置VoIP
举报原因:
原因补充:

(最多只允许输入30个字)