几个简单的voip的小例子

转载 2007年10月13日 22:31:00
 几个简单的voip的小例子
Jul 22, 2006
实验拓扑 

(phone A & phone B)-fxs-local router-----------(serial link,voip link)-------
remote router-fxo-PBX--phone C 


配置实例: 
1、基本配置: 



远端: Remote_Router#sh running-config 
Building configuration... 




hostname Remote_Router 
..................................................... 

interface Ethernet0 
ip address 192.168.1.2 255.255.255.0 
no ip directed-broadcast 
! 




router eigrp 100 
network 192.168.1.0 
no auto-summary 
! 
ip classless 
no ip http server 
! 
! 
! 
voice-port 1/1 
! 
voice-port 1/2 
! 
voice-port 1/3 
! 
dial-peer voice 10 pots 
destination-pattern 2203 
port 1/1 
! 

end 

本端: Local_Router#sh running-config 
Building configuration... 

.................................................... 
hostname Local_Router 

interface Ethernet0/0 
ip address 192.168.1.1 255.255.255.0 
half-duplex 
no clns route-cache 
! 
router eigrp 100 
network 192.168.1.0 
no auto-summary 

voice-port 1/0/0 
! 
voice-port 1/0/1 
! 
voice-port 1/1/0 
! 
voice-port 1/1/1 
! 

dial-peer voice 10 pots 
destination-pattern 2201 
port 1/0/0 
! 
dial-peer voice 20 pots 
destination-pattern 2202 
port 1/0/1 
! 
dial-peer voice 30 voip 
destination-pattern 2203 
session target ipv4:192.168.1.2 

end 




测试命令: 



call 通本端的两部电话机 
Local_Router#csim start 2201 
csim: called number = 2201, loop count = 1 ping count = 0 
. 
csim: loop = 1, failed = 0 
csim: call attempted = 1, setup failed = 0, tone failed = 1 
检查本地配置 
Local_Router#sh dial-peer voice summary 
dial-peer hunt 0 
AD PRE PASS OUT 
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT 
10 pots up up 2201 0 up 1/0/0 
20 pots up up 2202 0 up 1/0/1 
30 voip up up 2203 0 syst ipv4:192.168.1.2 
call 通远端的电话机(2203call通pbx,pbx提供2次拨号音,然后拨号468,对端电话号码响) 
Local_Router#csim start 2203,468 
csim: called number = 2203,468, loop count = 1 ping count = 0 
. 
csim: loop = 1, failed = 0 
csim: call attempted = 1, setup failed = 0, tone failed = 1 
其中","的含义是等待2秒 




下面给出几个需求可以稍作验证: 
1、需要配置语音网关的传真速率为9600,同时要消除舒服噪音。 

Local_Router#conf t 
Enter configuration commands, one per line. End with CNTL/Z. 
Local_Router(config)#dial-peer voice 30 
Local_Route(config-dial-peer)#fax rate 9600 
Local_Route(config-dial-peer)#end 
Local_Router#sh dial-peer voice 30 | in fax 
Cisc NSE=100, fax=96, fax-ack=97, dtmf=121, fax-relay=122 
fax rate = 9600, payload size = 20 bytes 
fax protocol = system 
fax-relay ecm enable 
fax NSF = 0xAD0051 (default) 
--------------------------------------------------------------------- 
针对舒服噪音,默认情况下 
Local_Router#sh voice port 1/0/0 



Foreign Exchange Station 1/0/0 Slot is 1, Sub-unit is 0, Port is 0 
Type of VoicePort is FXS 
Operation State is DORMANT 
Administrative State is UP 
No Interface Down Failure 
Description is not set 
Noise Regeneration is enabled-----------------------------〉打开 
Non Linear Processing is enabled 
。 
。 
。 
。 
配置后: 
Local_Router#conf t 
Enter configuration commands, one per line. End with CNTL/Z. 
Local_Router(config)#voice-port 1/0/0 
Local_Route(config-voiceport)#no comfort-noise 
Local_Route(config-voiceport)#end 
Local_Router# 
*Mar 1 00:37:19.735: %SYS-5-CONFIG_I: Configured from console by console 
Local_Router#sh voice port 1/0/0 



Foreign Exchange Station 1/0/0 Slot is 1, Sub-unit is 0, Port is 0 
Type of VoicePort is FXS 
Operation State is DORMANT 
Administrative State is UP 
No Interface Down Failure 
Description is not set 
Noise Regeneration is disabled---------------------------〉关掉了 
Non Linear Processing is enabled 



2、需求配置所有跑到VOIP上面的流量将优先级设置为1(我的设备不支持这一个所以没有作),同时采
用缩位拨号。 
Local_Router#conf t 
Enter configuration commands, one per line. End with CNTL/Z. 
Local_Router(config)#num-exp 0 2201 
Local_Router(config)#end 
Local_Router#sh num-exp 
Dest Digit Pattern = '0' Translation = 
'2201' 



3、需求配置跑在VOIP上的最大连接数为100,同时要求电话B先响。 
Local_Router#conf t 
Enter configuration commands, one per line. End with CNTL/Z. 
Local_Router(config)#dial-peer voice 30 
Local_Route(config-dial-peer)#max-conn 100 
Local_Route(config-dial-peer)#exit 
Local_Router(config)#dial-peer voice 10 
Local_Route(config-dial-peer)#preference 1 
Local_Route(config-dial-peer)#end 

Local_Router#sh dial-peer voice 30 | in max 
incoming called-number = `', connections/maximum = 0/100, 
incoming COR list:maximum capability 

Local_Router#sh dial-peer voice su 
dial-peer hunt 0 
AD PRE PASS OUT 
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT 
10 pots up up 2201 1 up 1/0/0 
20 pots up up 2202 0 up 1/0/1 
30 voip up up 2203 0 syst ipv4:192.168.1.2 



4、需求配置语音网关2为次选 
Local_Router#conf t 
Enter configuration commands, one per line. End with CNTL/Z. 
Local_Router(config)#dial-peer voice 40 voip 
Local_Route(config-dial-peer)#destination-pattern 2203 
Local_Route(config-dial-peer)#session target ipv4:4.1.1.1 
Local_Route(config-dial-peer)#preference 1 
Local_Route(config-dial-peer)#end 



Local_Router#show dial-peer voice summary 
dial-peer hunt 0 
AD PRE PASS OUT 
TAG TYPE MIN OPER PREFIX DEST-PATTERN FER THRU SESS-TARGET STAT PORT 
10 pots up up 2201 1 up 1/0/0 
20 pots up up 2202 0 up 1/0/1 
30 voip up up 2203 0 syst ipv4:192.168.1.2 
40 voip up up 2203 1 syst ipv4:4.1.1.1 





以上是一个初级配置,以后有好的再贴。

IOS实现Voip应用后台运行需要的几个配置项

voip类的app允许用户使用Internet网络而不是手机的蜂窝网络打电话,因此这一类的app需要保持同它相关的服务的网络连接,用以厚道来电消息和其他数据。IOS系统不是通过一直让app处于激活状态...
  • ji5ji
  • ji5ji
  • 2016年06月17日 22:44
  • 2707

VOIP通信中影响语音质量的因素

在VOIP通信中,影响语音质量的因素比较多,归类起来就以下几个大的因素: 1、网络因素,网络一般体现在网络的延迟、抖动、丢包。延迟一般是有语音的编解码速度、JitterBuffer延迟、TCP/...
  • huoyin
  • huoyin
  • 2014年11月13日 13:19
  • 1693

几个简单的博弈例子

几个简单的博弈例子 博弈的本意是下棋,现在也引申为:在一定条件下,遵守一定的规则,一个或几个拥有绝对理性思维的人或团队,从各自允许选择的行为或策略进行选择并加以实施,并从中各自取得相应结果或收益的过程...
  • Fries062
  • Fries062
  • 2016年10月10日 20:59
  • 745

Java几个简单例子

例子1 Class.isPrimitive()方法:判断Class类是否是基础数据类型 Class.isAssignableFrom:用来判断一个类Class1和另一个类Class2是否相同或是另...
  • u013485533
  • u013485533
  • 2015年02月10日 16:59
  • 308

几个简单php例子

1.is_函数 对变量进行种类判断 ()函数 强制转换 2.几个系统常量 其中line是魔术常量 运行结果 3.全局变量global 运行结果...
  • u012282037
  • u012282037
  • 2014年02月27日 10:53
  • 621

php中几个简单的例子

1.可变变量的使用
  • a5421901
  • a5421901
  • 2014年09月22日 17:11
  • 216

基于Linux开源VOIP系统LinPhone[三]

在LinPhone这个系统中,第二个我们要介绍的第三方库组件:speex,Speex是一套主要针对语音的开源免费,无专利保护的音频压缩格式。Speex工程着力于通过提供一个可以替代高性能语音编解码来降...
  • wavemcu
  • wavemcu
  • 2013年02月05日 14:18
  • 5213

VOIP开源项目源码地址

VoIP bookmarks from Klaus Darilion Below you will find descriptions and links to SIP and RTP stac...
  • htt9931
  • htt9931
  • 2015年04月14日 16:38
  • 1501

怎样打开VOIP与SIP

什么是VOIP?     VoIP的完整名字是Voice over Internet Protocol,翻译过来就是因特网语音,可以简单理解为一种用因特网系统代替传统电话通讯系统进行语音通话的技术。...
  • wds1181977
  • wds1181977
  • 2013年12月24日 18:18
  • 2279

自己动手搭建免费VoIP服务器

通过使用开源软件Asterisk,自己动手搭建免费VoIP服务器。 服务器别闲着,博主又要给大家带来新的玩法咯 1. 这里以 Debian 为例子,安装 Asterisk apt-get upda...
  • yuesichiu
  • yuesichiu
  • 2014年12月03日 10:28
  • 13380
内容举报
返回顶部
收藏助手
不良信息举报
您举报文章: 几个简单的voip的小例子
举报原因:
原因补充:

(最多只允许输入30个字)